Best answer

Unable to locate my Google Form spreadsheet

  • 15 March 2021
  • 3 replies

I’ve created a new Google form and connected it to a new spreadsheet where responses will be sent.


But when I try to create a zap which is triggered on new response in the spreadsheet mentioned above, it is unable to find the spreadsheet (see image attached). 


I’ve tried logging in and out of zapier and creating a different zap but nothing is working. I’ve never had this issue before and have made multiple zaps triggered by google forms. Please help!


Best answer by william 22 June 2021, 19:28

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

3 replies

To add to the above - 


I just created a new Google form and was able to find the responses spreadsheet on the zap.


The Google form that I was trying to link earlier was a copy from a previous Google form. I’ve tried making another copy of that form and I have the same issue of not being able to find the corresponding spreadsheet.


Could it be something to do with the fact that the Google form I’m trying to connect was created as a copy of another Google form? If so, that seems a bit ridiculous...

Userlevel 7
Badge +11

Hey @KK-CM,

Sorry to hear you’re having some trouble locating the spreadsheet for your Google Form. When you copied the form did you also connect it to a different spreadsheet? 

If it’s not connected to it’s own unique spreadsheet, that might be why it’s not showing up in the dropdown menu.

Do you think that could be the case here?

Userlevel 3
Badge +6

Hey @KK-CM, hope you’re well, I juste wanted to check in here!

Were you able to get things working, or can we still help here?

Here’s an article that covers this common issue:

For the original sheet that was copied, I would recommend re-selecting the spreadsheet the form is saving responses to. Then try checking the zap for the form after it is connected to a new sheet.