Question

Total newbie: help setting up google drive to youtube zap

  • 3 September 2020
  • 14 replies
  • 414 views

Userlevel 2

Hi there-

I just tried creating my first Zap, set to create a YouTube every time a file is placed into a folder on the G Drive. I’m getting stuck on the data I need to enter on the YouTube side for Title, Description, and Video. Where am I getting those? Thanks!


This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

14 replies

Userlevel 7
Badge +14

What do those data points (Title, Description, etc.) exists currently? (e.g. in a GSheet)

For example, you could add a step before to do a GSheets - Lookup Row to get those data points.

 

Userlevel 2

Thanks Troy. I’m having an issue with getting a movie to load into YouTube. I keep getting the error “There was an error with YouTube: The app returned "Media type 'text/plain' is not supported." I feel like I’ve not entered the correct data but don’t know how to fix it.

 

Userlevel 7
Badge +14

Please share a screenshot of how you have the YouTube Zap step configured.

Userlevel 2

 

Userlevel 7
Badge +14

Help: https://zapier.com/help/create/basics/different-field-types-in-zaps#step-4

You’re trying to pass in the Title of the uploaded file as a Video field, which expected a media file.

You need to pass in the File from GDrive for the Video field.

 

Userlevel 2

Thank you! The test worked but now it doesn’t seem to be automatically working when a new file is added to the folder. When I manually run it, it says there is no new file even though I added a movie. It doesn’t appear that the file has been uploaded to YouTube but maybe it takes longer than I’m giving it?

Userlevel 7
Badge +14

You’ll want to check your Zapier Task History: https://zapier.com/app/history/

Userlevel 2

I have, and it does not show anything from today.

Userlevel 7
Badge +14

Is the Zap turned ON?

Has a new file been added to the GDrive Folder AFTER the Zap was turned ON?

I suggest checking and doing another test.

Userlevel 2

I went in and ran a test again, and then the two movies that were in the folder uploaded into YouTube successfully. Am I missing something to have this run automatically?

Userlevel 7
Badge +14

These are NOT instant triggers (would be indicated with INSTANT if it were).

It then depends on your Zapier plan how quickly the Zaps will check for the trigger (aka Update Time).

Check Plans here: https://zapier.com/app/billing/plans

 

Userlevel 2

Aha! Thank you. 

Userlevel 2

It seems the only way for this to work is for me to run a test. Then the videos appear. When I do a manual run, I get the error saying no new files have been found. 

Userlevel 7
Badge +8

@hmizia - checking in to see if you were able to get this Zap up and running! If you are still encountering issues, it may be best for our Support team to take a look at your configuration. They can be reached here!