Best answer

The date I entered was set 1 day before that

  • 23 December 2020
  • 4 replies

Userlevel 1


Hopefully you can help me.. for a client in the Netherlands, I've built a Zap to add/update a Mailchimp subscriber based on a Google Form. There is an extra field added to Mailchimp: Start date (date her online course starts). The hard date I added to the Zap in this case is the 4th of January 2021. The date I see in Mailchimp and that returns in my test is the 3rd of January 2021?! 

I tried using different formats, even used the formatter after the trigger, but nothing seems to work. I'm almost sure it has something to do with the timezone. I set the timezone of Zapier to Amsterdam and the timezone in Mailchimp is the same. 

Does anyone here have the solution or maybe some other ideas I can try? 




Best answer by agnesveltboei 23 December 2020, 20:25

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

4 replies

Userlevel 5
Badge +5

Hey @agnesveltboei,

I would have also tried the steps you described. Did you try what arrives when you for example send it to a google sheet or slack instead of Mailchimp? Just to try where this error comes from.


Let me know! :)

Userlevel 1

Hey @Ennes,

Thanks for your quick reply! I'm not sure how to follow your suggestion.

In the Google Form, no date is added. I added a custom field (Start Date) in Mailchimp with the date format (dd/mm/yyyy) and UTC +1 Amsterdam. In Zapier, every time a Google Form is filled and therefore sent to Mailchimp to add/update a subscriber, I also fill this field. But I added this date manually for this specific Zap. 


How can I send it to Google Sheet? It would be a different field, right? Because it would be in the automation part of the field filling of Google Sheet. 


This is the field in Zapier (that corresponds to STARTDATE in MC), which I filled now with 01-04-2021 (4th of Jan)


The test returns this (this is new..):


But in Mailchimp:


It makes no sense to me anymore :D 

Userlevel 1

Fixed the issue by adding time and UTC. 

Userlevel 5
Badge +5

@agnesveltboei Oh nice! Happy for you :)