Best answer

Teams SharePoint Excel update

  • 28 October 2020
  • 7 replies
  • 1544 views

Userlevel 1

Hello All,

I’m having a hard time updating an Excel sheet located on a Teams Sharepoint.  I’m using the Excel > Add Row action but I’m having hard time locating the file.  I’ve noticed that the Sharepoint comes with a note: 

NOTE that this defaults to OneDrive. If Sharepoint is picked, subsequent folders that would be listed are ONLY folders in the default Sharepoint site. Other custom Sharepoint sites are currently not supported.

Does this mean that Teams Sharepoints are custom?  If not, what would the first bit of the file path look like?  I’ve tried a few, like /teams/(team name)/General/ which seems to be the path when I select the file path through Sharepoint.

If the Teams SharePoint is custom and I can’t use it directly in the update row, has anyone found a workaround?  Given how Teams and Sharepoint work together, I can’t imagine I’m the only one attempting to do this.

Thanks!

 

I’ve seen a similar post from Zappin but was unclear if this was the same issue they ran into. 

icon

Best answer by kstamm 10 November 2020, 20:15

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

7 replies

Userlevel 7
Badge +9

Hello! Would you be able to share a screenshot/short video of the issue you’re running into? (i.e. where in Zapier you are setting this up)

Userlevel 1

@andywingrave Thanks for the response!  See attached.  Other than Root the folder, there are no options or files available to select.  I’m unclear how I could path the folder to the Teams Sharepoint I’ve setup, it is not listed as an option.  Any advice would be appreciated!

Userlevel 7
Badge +9

What happens if you hard-code a value there - Can you create a folder?

Userlevel 1

I’ve tried hardcoding a value but get an error every time.  I don’t understand where the root folder of Sharepoint would actually go or how to path away from there.  The root seems to be totally empty.  When viewing Sharepoint I am forced into one of the Team Sites, not a root folder I navigate from.

 

When I look at the path of the file I want to edit it looks similar to the below:
/teams/teamname/Shared Documents/Forms/foldername/filename

But after trying to hardcode different iterations of that, even just /teams, I still end up with errors and no search results.

Userlevel 7
Badge +9

Hmm - Is there any chance it could be a permissions issue? This *might* be one for Zapier support sadly, as I can’t replicate :confused:

Userlevel 1

I don’t think it’s permission based, as I’m successfully logged in everywhere I’m supposed to be in the Zap.  I don’t receive an error other than the path name itself, but I’m not sure what it could be.  I’ve sent Zapier Support a message.  Thanks for the assist!

Userlevel 1

As a follow up:
This is impossible with the current Sharepoint API.  Files separate from your default Sharepoint location, which considering my company is massive I don’t have access to, aren’t accessible in Zapier.  For instance, any Teams Sharepoint locations are inaccessible in Zapier, as they have their own location separate from that linked to your account.