Best answer

Syncing Empty Source Field

  • 13 September 2022
  • 7 replies
  • 287 views

Hi, I have a Zap designed to send Airtable address fields to corresponding address fields in Cognito Forms.  I noticed that if a Cognito record has a filled “address 2” field (for apt/unit/suite, etc.), and I then make address changes in Airtable that include deleting the data in that field, the Zap will push the update but ignore the change of having text in the field to having no text in the field.  So for example if somebody moved from an apartment to a house, Cognito would then have all the correct address data for the house but still list “apt X” in the record.  How can I get Airtable to push the empty field so that it updates the destination?

 

 

icon

Best answer by christina.d 26 September 2022, 21:39

View original

7 replies

Userlevel 7
Badge +9

Hey there, @armandav! Great question and appreciate you raising this in the Community! 

I did some digging and it looks like clearing the contents of a field isn’t possible at the moment. 😔

There’s some recommendations in that thread that could be useful though! I hope this helps. 🙂

Thanks, I tried doing the three space thing but that didn’t work.  Also not ideal because anyone updating records in the database would need to know this quirk instead of just deleting the data as one would expect to work just fine.  I have another Airtable formula field that aggregates all the address data into a single field, and I think I can modify my Cognito form to use that field instead, in which case Zapier should pass through all the changes just fine.  So I have a workaround but this seems like something the Zapier devs should address. 

This may be related to another annoyance I have, which is building Zaps where a test record may not include data in every field intended to be part of the Zap. I need to add dummy data or keep refreshing until I find a record that has data in all the desired fields.  It seems there could/should be an option in the Zap settings for the source on whether to include or exclude empty fields.

Userlevel 7
Badge +8

Hi @armandav 

 

You are correct, because usually when a field is empty the app API (in this case Airtable) does not send this field to Zapier , so Zapier cannot read it.  Alternatively, if its a formula field, you can always have an IF statement where if Address 1 is Blank() then Blank(), this would push it to Zapier to specify that the field is blank. 

Userlevel 1
Badge

This is an issue that users can imagine be there in apps like Airtable and Zapier; I believe both of one of them needs to solve it. 

On the Face everything seems fine and eventually when you run your Zap its stuck. And shockingly it is related to a field that does not get value from Airtable.

I guess it becomes more of a Zappier problem than Airtable as Zapier should easily be able to let he users decide what to do what no value comes in a field from Airtable.

Please resolve this soon.

 

Userlevel 7
Badge +8

Hi @KPFS 

 

The Zap shouldnt stop if the field is empty unless its mapped to a required field in the next step of the zap. Otherwise the zap will continue even if the field is empty. 

Userlevel 1
Badge

Thanks @MohSwellam,

 

At the outset, I must admit my bad; I should have checked thoroughly. I realize there were 2 (out of the 100s) I configured and I marked them as required in my target app (Zoho Sign).

Thanks to your email; I double checked and I got it

 

I like everything you do!

Userlevel 7
Badge +9

The Zap shouldnt stop if the field is empty unless its mapped to a required field in the next step of the zap. Otherwise the zap will continue even if the field is empty. 

 I realize there were 2 (out of the 100s) I configured and I marked them as required in my target app (Zoho Sign).

 

Whoop!  It sounds like unmarking those fields as “required” in Zoho Sign was the answer here! I went ahead and summarized the what ended up doing the trick in case it’s helpful to anyone following along. 🤗
Thanks for sharing your end solution with the Community, @KPFS ! We love to see it.

Reply