Best answer

Squarespace form submission not triggering MailerLite Automation

  • 1 July 2021
  • 5 replies
  • 251 views

Userlevel 1

Hello Zap Geniuses!

I’m tearing my hair out.

I have a client on SquareSpace, and she is using MailerLite for her email marketing.

I have implanted a SquareSpace newsletter form on her website, and contacted it to MailerLite.

I could NOT get the form submissions to be added to the specified Group using SS native integration with MailerLite, so I created a Zap to add them to the Group. That works.

I then created an automation in MailerLite to send an auto-email that I created when a subscriber joins the specified group. However I cannot for the life of me get the automation to run. I have tested ad nauseam and even duplicated the site, removed all extraneous header code and integrations, and it still will not run. 

Anyone run into this and how to resolve it?

Thanks so much in advance.

icon

Best answer by Troy Tessalone 1 July 2021, 23:20

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

5 replies

Userlevel 7
Badge +14

Hi @Fat Cat Design 

Perhaps you can post screenshots of how your Zaps are configured.

 

TIP: Make sure to test with unique data points, or reset/delete data points that may already be in an existing app.

 

LOGIC

  1. If the MailerLite Automation won’t trigger, then that’s likely an issue in MailerLite and not with the Zap. (http://help.mailerlite.com/article/show/29187-creating-an-automation-workflow)
  2. If the Zap won’t trigger, then that’s likely an issue with the SS form or with the Zap trigger.
  3. If the Zap triggers, but the data isn’t making it to MailerLite, then that’s likely an issue with how the Zap is configured.
Userlevel 1

Hi @Fat Cat Design 

Perhaps you can post screenshots of how your Zaps are configured.

Hi Tony :)

I can do better than screenshots :)

I created a screencast showing the entire configuration. 

 

TIP: Make sure to test with unique data points, or reset/delete data points that may already be in an existing app.

I’m not sure what you mean by that?

 

LOGIC

  1. If the MailerLite Automation won’t trigger, then that’s likely an issue in MailerLite and not with the Zap. (http://help.mailerlite.com/article/show/29187-creating-an-automation-workflow) - yes I followed this religiously.
  2. If the Zap won’t trigger, then that’s likely an issue with the SS form or with the Zap trigger. - the Zap is triggering, it’s the ML integration that is not.
  3. If the Zap triggers, but the data isn’t making it to MailerLite, then that’s likely an issue with how the Zap is configured. - the Zap is triggering, and the data is making it to ML, but it’s the automation that is not triggering.

 

Userlevel 7
Badge +14

Hi @Fat Cat Design 

I suspect the grayed out subscribers that are added to the group have to do with a ML double opt-in setting, meaning the automations won’t run until the subscriber confirms their opt-in.

http://help.mailerlite.com/article/show/29231-what-is-double-opt-in-and-how-does-it-work

 

If the Zaps are behaving as expected and the issue is with MailerLite, then you may have to reach out to MailerLite Support for assistance with their Automations functionality: https://www.mailerlite.com/support

Userlevel 1

Hi @Fat Cat Design 

I suspect the grayed out subscribers that are added to the group have to do with a ML double opt-in setting, meaning the automations won’t run until the subscriber confirms their opt-in.

http://help.mailerlite.com/article/show/29231-what-is-double-opt-in-and-how-does-it-work

Thank you Troy :) 
The thing about this form is that it is not a ML-generated form. It is a SS newsletter form generated on the native SS platform. I do have double-opt-in disabled on said SS newsletter form. 
What’s odd is that all of the testing I’ve performed, when a subscriber was successfully added, said subscriber was not grayed out til a few hours ago.

 

If the Zaps are behaving as expected and the issue is with MailerLite, then you may have to reach out to MailerLite Support for assistance with their Automations functionality: https://www.mailerlite.com/support

Thank you, yes I have. They are slow to respond, unfortunately. 

 

Userlevel 1

Hi @Fat Cat Design 

I suspect the grayed out subscribers that are added to the group have to do with a ML double opt-in setting, meaning the automations won’t run until the subscriber confirms their opt-in.

http://help.mailerlite.com/article/show/29231-what-is-double-opt-in-and-how-does-it-work

 

If the Zaps are behaving as expected and the issue is with MailerLite, then you may have to reach out to MailerLite Support for assistance with their Automations functionality: https://www.mailerlite.com/support

Hi Troy - yes, this was exactly the issue! Thank you!