Best answer

Square Integration's "Created at" Date Incorrect

  • 12 September 2020
  • 6 replies
  • 138 views

Userlevel 1

Greetings,

I have a Zap set up that adds a row to a Google Sheet each time there’s a sale in our Square Point of Sale (POS).  One of the fields is called “Created at: and it returns the wrong timestamp.

Zapier filled in this timestamp (9/11/2020  0:43:49) when the actual transaction occurred on 9/10/2020  around 21:30:??.  My timezone is Eastern Standard Time.

Does anyone have a suggestion on where I should start my troubleshooting.

Thank you.

Chris

icon

Best answer by Troy Tessalone 12 September 2020, 16:11

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

6 replies

Userlevel 7
Badge +14

Check these Time Zone settings:

  1. Zapier Account
  2. Zap
  3. GSheet
  4. Square
Userlevel 1

Thank you Troy, found the timezone setting under the “Info” icon on the Zaps homepage.  That’s adjusted and I’ll watch for the next entry to see it in action.  Appreciate your assistance!

Userlevel 1

Hi @Troy Tessalone 

After adding our timezone, I’m still consistently getting a one hour difference.  For a transaction that actually occurred at 11:43 am, the ZAP downloads as 10:43 am.  I’m guessing this is daylight savings time, but I can’t find any setting to accommodate for it.  This setting seems pretty straight forward so I don’t think I’m missing something.

Any idea? 

 

 

Note:  I live in Fort Wayne, IN, USA. (Easter Timezone)

Userlevel 7
Badge +8

Hi there @Flopbot - Here’s a handy guide on how to format time and dates in Zapier: https://zapier.com/help/create/format/modify-date-formats-in-zaps

Could you take a look and see if this was helpful?

Userlevel 1

Hi Steph,

 

Thank you very much for your suggestion. I looked it over, but didn’t find anything that fixed my issue.  The problem doesn’t appear to be the format of the date/time (1:30 pm, 1:30 PM, 13:30, etc.), it - I think - has something to do with daylight savings time since it’s consistently off by one our.

 

To confirm this, the only thing I can think of is to wait till after November 1st when Daylight Savings changes back and then see what happens.

Userlevel 7
Badge +8

@Flopbot - I’m sorry the suggestion didn’t work as expected. 

If you’d be willing to report back to us or even try disabling DST features on your computer (I have done this on my own machine before) to see if that toggles this change for you, we’d love to hear if you find a solution. Thank you!