Square-Gmail integration. Not sending email

  • 30 January 2021
  • 14 replies

I have a zap set up to send an email to a customer with the digital item they purchased. It fliters the correct product name and then is supposed to send them a email with necessary links. However, even though the email shows up in the test data. When I real time test the zap it doesn't send the customer any email. In fact it has the information marked as blank. How can i fix it? is there re-formatting that has to be done? 

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

14 replies

This is what is coming up when I view zap history. It says the zap was successful but not really:/

I tried using zapier formatting and its not pulling the email either. Do I have to write my own code to parse this data out.

Userlevel 7
Badge +14


Check your Zap Runs to see if the email data point comes thru on your real-time test:

Created a code step to grab the email. data is still undefined. I'm running the test transactions so i know I'm putting in the email...does anyone know what the problem could be?

Userlevel 7
Badge +14

@kookykullaf If the email data point is undefined in/from the trigger data, then the issue is with the trigger providing the email data point, not the Zap.




I checked the zap history for every attempt and every time it's undefined.

Recent Errors:

w/o the custom code: Required field "to" (to) is missing.

w/ custom code: TypeError: Cannot read property 'match' of undefined


My zap is:

Trigger: New Square Transaction

Filter: for a certain product

(new): js code that pulls out only the email address in plain text

Action: Send Gmail with specific link for that product - I put the transaction email in the to field


Userlevel 7
Badge +14

@kookykullaf You can open a ticket with Zapier Support here:

thank you for helping me troy. So does this having something to do with the data that square is giving me? 

when I ran the test trial (not real-time) it said it succeeded in pulling out the email and everything looked fine. Real-time test it was undefined. 

@kookykullafYou can open a ticket with Zapier Support here:

doing that now thank you

I’m having this same issue - @kookykullaf Did you get a fix?

Userlevel 7
Badge +11

Hi @MMR!

I see that the OP contacted support and the result there was that the customer email address is not something that is included in the data for the New Transaction trigger. I’m not 100% sure why it’s provided in the sample data when editing the Zap, if it’s not going to come through when the Zap runs.

We do have an existing feature request to add that piece of info and I’ve added you to that. You’ll be notified via email if/when it gets implemented :)

Thank you for the update. Yeah, that seems like a no brainer since the only way to add information to mailchimp is using the email address.

If you know of another way to capture that transaction data, I’d be all ears.


Userlevel 7
Badge +14

Got this feedback from a client facing the same issue and wanted to share…


Supposedly if a discount code is used to purchase the digital item for free ($0), then these “free” transactions don’t transfer the name and email data.

Userlevel 7
Badge +10

Just checking in to see if you still need help with this?