Best answer

Slow Performance with Google spreadsheet

  • 2 February 2021
  • 5 replies
  • 921 views

Hello, 

 

I have a Zap that looks for a new row in Google Spreadsheet, and sends to data to the webhook. at the beginning it was working pretty nice. However right now, when I have more than 1000 records in the Spreadsheet it takes more than 15 minutes to trigger zap, and I see that this time is increasing with each new record. turning zap off - on won't help. 

could you please advise any solution? 

 

icon

Best answer by Troy Tessalone 2 February 2021, 17:10

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

5 replies

Userlevel 7
Badge +14

Hi @Anton 

The Google Sheets trigger is marked "instant" but it still takes a few minutes to trigger

The triggers for Google Sheets are unique among Zapier triggers. When there is a trigger event in the spreadsheet, Zapier gets a notification webhook from Google about this. After that, Zapier sends Google Sheets a request for new data, so it uses both the polling and instant trigger methods. This process takes about 3 minutes overall.

While not being "instant", these triggers are faster than regular polling ones, as they don't depend on the polling interval of the plan your account uses.

Hi Troy! 

 

thanks a lot for a prompt response. That was at the beginning,  and 3 minutes is perfectly fine for me. so far, I am on a professional plan, so a presume it shouldn’t take more than a couple of minutes. however, last time it took 24 minutes to send data from Google to webhook - which is already a problem for me… 

Userlevel 7
Badge +12

It might be helpful to turn the Zap off and clean up the spreadsheet so that you have less rows and then turn the zap back on.

Userlevel 7
Badge +14

@Anton 

Google spreadsheets are not optimized for large volumes of information (spreadsheets with around 10,000+ rows), and this can make it a challenge to access them via Zapier. Here are some things to keep in mind:

  1. Consider starting a new spreadsheet with less data in it, or moving/deleting any columns not being used on the Zap. If you choose to move/delete rows, make sure the Zap is off while you do this. Once you're done, you can turn your Zap back on.
  2. If this error pops up with Google Sheets as the trigger, there is little concern about data loss since the Zap will probably catch the data the next time it runs. That said, over time these errors can become more frequent and potentially cause your Zap to be turned off, as there are too many errors.
  3. If this error appears with Google Sheets as the action, then there will likely be data loss. The Zap might not be able to complete sending data to Google Sheets due to the size of the spreadsheet. To recover from this, try replaying that specific task from your task history.

If you're considering an alternate solution, an app like Airtable, or a database, like MySQL, can help better handle large databases.

Userlevel 7
Badge +12

 

Hi @Anton!

I’m sorry that you’re running into this trouble with your Google Sheets trigger. We do know that there’s an issue affecting some Google Sheets Zaps, but it’s difficult to diagnose whether or not you’re running into that issue without the Zapier support team taking a closer look at your Zap.

If the Zap doesn’t work after you’ve turned it off and on again and you’ve checked the points that @Troy Tessalone and @GetUWired mentioned then the best thing to do is to get in touch with the Support Team so they can take a look.

When you do, please don’t forget to mention the steps that you’ve already taken, so they know where to start. You can contact the Support Team using the Get Help form: https://zapier.com/app/get-help