Best answer

Slack attachment data is missing from trigger

  • 15 July 2021
  • 5 replies

Userlevel 1

I seem to be having a similar problem as this thread: 


I have a “New Message Posted to Channel in Slack” trigger setup, and it does receive data when i post new messages to the channel, however none of those messages include any attachment information at all. If i post a message with some text and an image, only the text is available from the trigger output.


I’ve tried the workaround mentioned in that thread and used the “Find Message in Slack”, and it is able to find the initial message, however that found message also does not include attachment data.


Is there a setting I need to configure to enable attachments? or is there another way to set this up so that all of the attachment data is included?




Best answer by christina.d 15 March 2023, 23:14

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

5 replies

Userlevel 7
Badge +9

Hi @adam.wulf 

As described here by Zapier, the attachment data should be included in the message received by Zapier trigger:

Can you try with some more messages to see whether the attachment data is received or not?

Userlevel 1

Hi, thanks for the reply. Yes, I’ve tried with numerous different messages, with many different types of attachments - text files, images, video, etc. the attachment data is never included. I’ve also tried two evenings in a row as well, both on day old messages and recently posted ones. In all cases, the attachments never show up.

Userlevel 7
Badge +12

Hi @adam.wulf 

This is currently a known issue with the “New Message Posted to Channel in Slack” trigger, I’m sorry about that.  I've added you as an affected user on the issue report, which lets the team know how many users have been affected and also means that we will send you an email if we have an update on this.


As far as I’m aware, searching for a message using the Find Message action should work. If you’re having trouble finding an attachment that way, could I ask you to get in touch with the support team using the Get Help form? They’ll be able to take a closer look at the Zap and data with you to better understand what might be happening. Thanks!


Userlevel 1

Hi Danvers, thanks! I’m glad it’s a known issue, hopefully will be resolved soon. I’ve reached out through the help form and included all of the details I could.



Userlevel 7
Badge +9

This is currently a known issue with the “New Message Posted to Channel in Slack” trigger, I’m sorry about that. 

Hey friends! 👋🏽I wanted to swing by with a belated update!

A fix has been launched and the “New Message Posted in Channel” trigger now includes attachment info for bot messages.🤖 🎉

The caveat being any attachment info from a human message will still require the workaround. My pals in docs created a tutorial for this though.

Thanks for your patience and happy zapping!⚡️