Question

Shared Drive (G Suite) URL Not Working

  • 22 January 2021
  • 5 replies
  • 105 views

Userlevel 1

I understand there is a thread about entering the ID of a shared G Suite Drive (Team Drives). When I do so in a Google Sheet Zap, however, I get an error and the Zap says the ID is unrecognized.

I had Zaps working perfectly fine with a folder that was normally shared to me (editing a folder I owned inside). However, our team switched to the GSuite Organization feature called “Shared drives” which is this area of Google Drive.

When I try to set up the Zap with the new folder (that I own inside this Shared drive), Zapier is not able to access it. I have made the folder view access for all, I am the owner, I have a file in it, etc. I am an Admin of the org.

 

I think Zapier needs to add support for this. I believe the feature is fairly new. Many businesses will be, and are, using this.

 

Here are photos:

The old Shared folder is listed. The new “Shared drive” is not.
Thus, I manually input the folder ID, taken from the URL.
The error when trying to find a doc, and not make it.
The error when trying to make a doc when one cannot be found.

 

These help thread results do not work:

 

Again, I think Zapier needs to add support for this.

 

Thanks


This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

5 replies

Userlevel 7
Badge +10

@Putty 

I'm going to flag this post for the Zapier Community Team. They should have more insight on this and can escalate to the support team if needed.

Sit tight, and someone will contact you soon.

Userlevel 2
Badge

Hi @Putty,

Can you elaborate a little bit more on the trigger and action?

I use shared drives on 7 different zaps and they all work.

Did you try to set up a trigger, and then “find folder” in Drive (using the folder ID or the folder name), and after that, find a file in the folder you just found?

Userlevel 1

Hi @Putty,

Can you elaborate a little bit more on the trigger and action?

I use shared drives on 7 different zaps and they all work.

Did you try to set up a trigger, and then “find folder” in Drive (using the folder ID or the folder name), and after that, find a file in the folder you just found?

Yes, that is what I tried. I show two images of this process not working above.

Are you talking about “Shared Folders" or the GSuite Business section "Shared Drive”? It works on the former but not the latter.

Userlevel 7
Badge +11

Hey @Putty!

Did you see my response in this thread, by any chance:

 

Userlevel 1

Hey @Putty!

Did you see my response in this thread, by any chance:

 

Yes, I'm eagerly waiting a fix from your team. That solution does not satisfy my needs as I need to find a document, not create one.