Best answer

Sending an attachment with Gmail (from Jot Form)

  • 20 February 2021
  • 6 replies
  • 96 views

Badge

I have a form in Jot Form.

I have some values and an attachment in the form.

 

When I test my zap I receive this error:

The email could not be sent to Gmail.
The app returned "Not Found".

 

I cannot understand why.

I have already followed this: https://zapier.com/help/doc/jotform-values-are-missing-or-incorrect

 

Tks!

icon

Best answer by Raffoz 24 February 2021, 10:06

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

6 replies

Userlevel 7
Badge +14

Hi @Raffoz 

Please provide screenshots of how your Zap step is configured, thanks.

Badge

Tks, I attach all the images.

If I use Google Forms it works, but I hate the fact that Google Forms adds underscores in the white spaces of file names and that when user receives the attached file the name has underscores in it.

 

 

Badge

Sorry, in my previous post I wrote:

“If I use Google Forms it works, but I hate the fact that Google Forms adds underscores in the white spaces of file names and that when user receives the attached file the name has underscores in it.”

 

It’s Zoho Forms thats add underscores.

Google Forms adds name of the user who makes the upload as a prefix to the file name.

Userlevel 7
Badge +14

@Raffoz 

For the PDF URL you are testing with, check to make sure that PDF URL still exists, by copy/pasting into a browser.

If it does not resolve to display the PDF, then that’s the reason why the “Not Found” error occurs, and try testing by selecting a different example submission from the trigger step.

FYI: The PDF URL needs to be a publicly accessible URL, so check your JotForm attachment settings.

Badge

@Raffoz

For the PDF URL you are testing with, check to make sure that PDF URL still exists, by copy/pasting into a browser.

If it does not resolve to display the PDF, then that’s the reason why the “Not Found” error occurs, and try testing by selecting a different example submission from the trigger step.

FYI: The PDF URL needs to be a publicly accessible URL, so check your JotForm attachment settings.

 

Tks for your help Troy.

From what I can see there’s some problem with the connection between JotForm and Zapier for attached file.

 

If I paste the link of the file (.pdf) in a browser, the file is automatically downloaded, not displayed.

But apart from this, it’s all normal.

 

I don’t know what to do.

I think there’s some problem with JotForm .eu servers, this is my feeling.

Badge

I solved it.

In JotForm settings: must be disabled the “request login to see documents”.

 

Tks @Troy Tessalone!