Best answer

Salesforce error : Could not create record of the "Contact" object:

  • 21 April 2021
  • 5 replies

I started to connect SF with one of our zaps.


  • I  started to add Account lookup (or create if not found)
    • That provied the same error yesterday, but then magically started working after I got an email from Zapier support
  • Now I added that for Contact & Opportunity and both result in the same error
    • It does not matter if I use the account lookup ID or just hardcode any account, the same error comes up
    • So I cannot create either of those  objects, regardless of whether I use actual or fake dummy data


I already checked that we only have 5 connected apps for this login under OAuth applications, and beyon this have no idea what it could be


  • No issue creating any object in SF UI directly

Best answer by nicksimard 21 May 2021, 02:32

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

5 replies

Userlevel 7
Badge +14

Hi @Zapthis 

This might be an field permission issue related to the connected Salesforce account.


Found this explanation via a GSearch on the topic:

Profiles have record type settings.
This error means that the user has a profile for which that record type is not enabled.
You need to make sure the profile you're using has access to the desired record type, or that the value is being set in a "without sharing" class.

Userlevel 1

I also have the same issue “Could not create record of the "Contact" object” using the Salesforce (Premium) app.

This stopped working yesterday 05/18/21 around 2 PM EST. It was working fine for over a year, and I have not made any changes to any of the Zaps, or Salesforce.

I can also create a contact (read/write) with the same user logging into Salesforce via the web portal.

I also have a case with Salesforce but they already told me they cannot help me because they say this is a 3rd party app issue.


Please Help!


Matt Bruce

Userlevel 7
Badge +14


Have you reviewed these Salesforce Common Problems?

Userlevel 1

Hi Troy, 


Thank you for your reply.

Yes, I have and although I will continue to look at Salesforce, this does not seem like a Salesforce related issue to me.

Like I said in my original post, this was working for over a year, and all of a sudden stopped working on 05/18/21.


Matt Bruce

Userlevel 7
Badge +11

Hi @novarica!

I see that you contacted our Support team and you ended up finding the issue yourself :) 

I’m sharing here in case anyone else runs into this and finds it helpful:

I discovered that the issue was caused by the modification of a Salesforce "Duplication Rule" (from another Salesforce admin) that ran against contacts.

I have since added an exception to that rule and the Zaps are working again!