Best answer

Salesforce - Cannot deserialize instance of time

  • 18 March 2021
  • 6 replies

Userlevel 3

I have connected Calendly with Salesforce. I’m setting up the meeting time value to a lead field on Salesforce and getting the following error.


I tried all the following time formats that Salesforce accepts.

"2:40 PM", "14:40", "14:40:00", and "14:40:50.600"

I also tried the following time formats.

02:40 PM
2:40:00 PM
02:40:00 PM

But Zapier keeps showing me the error. What should I do to resolve this?


Best answer by Danvers 18 March 2021, 16:36

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

6 replies

Userlevel 7
Badge +10


I'm going to flag this post for the Zapier Community Team. They should have more insight on this and can escalate to the support team if needed.

Sit tight, and someone will contact you soon.

Userlevel 3

Thanks @AndrewJDavison_Luhhu. I will wait for someone to get more insights on this. :)

Userlevel 7
Badge +14

Hi @thinker500 

A GSearch on the error message returned these help articles about what appears to be a known error:

Userlevel 7
Badge +12

Hi @thinker500 


It could be that the time being sent from Calendly is not using the format that you can see in the Zap editor. You can see the time format that’s being sent in the error message:



In this case, you’ll need to get in touch with the Support Team so that they can take a closer look at your Zap and the information that’s being sent/received. The best way to do that is using the Get Help form.

Userlevel 3

Thank you, @Troy Tessalone. I already looked at those posts and found nothing conclusive. So I posted here on Zapier community. :)

Userlevel 3

Thanks, @Danvers for suggesting this. I think I should reach the support team.