Best answer

Ringcentral Zap stopped working

  • 16 October 2020
  • 5 replies

Userlevel 1

This Zap has been working for me for a long time and suddenly it’s not. It worked yesterday in fact. Nothing changed on my end. There are tons of call recordings in my account.

The Zap takes call recordings from RingCentral and adds them to a dropbox folder. I’m getting this error when I try to bring in sample data: Javascript Exception: `TypeError: Cannot read property 'contentUri' of undefined`.

Clicking on troubleshoot error takes me to this page:

But my RingCentral account has only one user account. To be sure, I signed in with all my phone numbers and my email address. I get the same error regardless of which “account” I choose.



Best answer by Troy Tessalone 18 October 2020, 00:19

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

5 replies

Userlevel 7
Badge +14

Is the issue still occurring?


It’s tech, sometimes there are glitches with apps whether that’s due to code updates, underlying technology having hiccups, etc.


Check your RingCentral app connection in Zapier here:


Here’s a related article found by doing a GSearch:


If you ever suspect something is up, be sure to check the STATUS pages for each app involved.



Userlevel 1

Yes, I’m still getting the same error.

My RingCentral app connections are working fine.

On that other thread you linked to, they were getting a different error and it resolved on its own.

All systems statuses are operational for RingCentral and Zapier.


Userlevel 1

I just reconnected my RingCentral account from scratch and created a Zap from scratch and I get the same error. This only happens when the trigger event is new call recording. Other triggers appear to work. How can we fix this?


Userlevel 1

I really need this Zap to start working again. Any ideas?

Userlevel 7
Badge +14

You can submit a support ticket to Zapier here: