Best answer

Resthook action succeeds but not carried out

I successfully got a Resthook trigger working.  When I add a new contact in my CRM the resthook executes and a new Google Sheets row should be created.  When setting up the Zap the testing all worked fine.  When I test the trigger I get back a success message from Zapier (along with identifying info) but the G Sheet does not get updated.  How can I diagnose this further?


Best answer by Greginns 5 May 2020, 00:41

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

13 replies

Userlevel 7
Badge +7

Can you please share some more details? The community is not able to look into your Zap workflows. Please share screenshot(s) of you current webhook, code, output etc.




When the Zap ran for real I got back this as a response:

data: {    id: '9ae1c7d1-7217-4d6a-a3c3-7829674b0cf8',    request_id: '5eaa1703-2a41-4c0c-be2f-91b0ad632d30',    attempt: '5eaa1703-2a41-4c0c-be2f-91b0ad632d30',    status: 'success'  },   How do I follow up on that info?   The Zap action is below, and it worked fine when testing.  But the action in real life says it succeeded but no new row was created.  I tried multiple IDs to rule out a de-dupe issue.   Thanks!  


Userlevel 7
Badge +7

Allright, so if I understand correctly your workflow looks like this:

  • You call a webhook of some sort
  • You create a Row in Google Sheets with the app

And the rows are not being created. Can you show a screenshot if the “Customize Spreadsheet Row” section? This will tell us some more info probably. It probably will be something misconfigured.
Running the first Trigger test + Action 2 creating a row in your worksheet works, correct?


Let me know

Yes, running the test worked fine.  A new row was added to my sheet.  I’m just using a random Sheet that already exists, so the column names don’t make any sense.  The ‘Drive’ value doesn’t seem to get saved, so I re-entered it and tried the real zap again, same issue.  (I’m assuming the Drive doesn’t need to be saved as the Sheet has a unique ID).


Userlevel 7
Badge +7

If you go to the Task History → Your Zapier workflow → and click on the “Data Out” for the first webhook action. What do you see there?

There is no entry for that Zap, just two from the test ‘Github Issues to Google Sheets’.  I’m just learning Zapier and this is my first real-ish Zap.  This is the full response from the latest webhook trigger.  My take is that the trigger worked fine.


  data: {
    id: '4028aeea-63da-45be-a6f0-340d29fe249c',
    request_id: '5eb03f77-e32b-41a4-a86b-f00be07af680',
    attempt: '5eb03f77-e32b-41a4-a86b-f00be07af680',
    status: 'success'
  headers: {
    'access-control-allow-origin': '*',
    'content-type': 'application/json',
    date: 'Mon, 04 May 2020 16:14:47 GMT',
    'response-id': '5eb03f77-e32b-41a4-a86b-f00be07af680',
    'strict-transport-security': 'max-age=31536000; includeSubDomains; preload',

    vary: 'X-Session-Key',
    'x-frame-options': 'SAMEORIGIN',
    'x-rate-limit-limit': '10000',
    'x-rate-limit-remaining': '9999',
    'x-rate-limit-reset': '1588609200',
    'x-session-key': 'anonymous',
    'x-zapier-fast-return': 'true',
    'x-zapier-jobs': 'A hacker like yourself should consider working at Zapier!'
    'x-zapier-jobs-link': '',
    'x-zapier-revision': '99f4fa697b2eae1197e84632dcd403904d0d96cc',
    'content-length': '172',
    connection: 'Close'
  status: 200,
  err: null

Userlevel 7
Badge +7

When there are no entries in the Task History from that Zap we are talking about now, then it’s not running / triggering live. The webhook is your trigger? It looks like this is not triggering the workflow.

Can you show a screenshot of your trigger and fields, and how you are trying to trigger this?

Trigger: when a contact is updated I send the data via a webhook to the Zapier supplied URL.  The body is an array containing one object.  I went over my server side send it looks good. I changed the Zapier URL for one of my end points and I get the data ok. 




Userlevel 7
Badge +7

I see you are using a custom created App. I am not sure how this app would work or how it recieves a Trigger etc. However, like said before; if there is no action in the task history the workflow is probably not being triggered.

Could you make sure this custom app works as intended? And to make sure it's this issue, use something else as a trigger (I always test with a “Push by Zapier with fields”) so you can still insert the needed data, but make sure it's the Trigger that is having issues.


Let me know!


I did the Push By Zapier with Fields to a Google Sheet (same as my test one) and it worked fine.  My History has a new entry.


Yes, my trigger is a custom app.  The app is working fine.  When I change a contact the POST is made to the URL Zapier gave me.  I know that I get a Success message and HTTP status 200 in return.  But I have no way of knowing anything more than that.  From the response I’d say it’s working.  From my History it’s clearly not. 

I heard from Zapier and my problem was that my Resthook push was sending an array, but it should have been a plain Object as the ‘perform’ routine made it into an array.  Duh.


Thanks for all of your help.

Userlevel 7
Badge +7

Good to know, unfortunately we can't look into that kind of data without you providing ;)
No problem! Great to see it fixed,

Userlevel 7
Badge +12

Thanks for all your help troubleshooting this, @ForYourIT !