Best answer

Reporter or users not being loaded from JIRA Software Server

  • 9 March 2020
  • 4 replies

Userlevel 3


we had this issue two weeks ago and thought it was solved however last week our zaps suddenly stopped working again, because there is something wrong with the way zapier is trying to request the users from JIRA and submitting them back to JIRA. (for instance in the reporter or asignee fields)

It's possible JIRA changed the required format because I've seen similar posts in the JIRA community. (I read on their website that they made some changes to how users are identified, in order to improve user privacy, but that was last year)

This issue might already have been submitted already but I can't find any status on this.

Hope you can help me out or give me an update.



Best answer by shwebteam 11 March 2020, 13:03

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

4 replies

Userlevel 7
Badge +12

Hi @shwebteam !

Atlassian released unexpected changes to their API, which caused a some issue to some users' Zaps. Both the JIRA Software Cloud and JIRA Software Server (self-hosted instances) should now work as expected.

If you're still encountering issues with the JIRA Software Server integration when attempting to assign a member and/or assignee for the "Create Issue" action, could you please try the JIRA Software Cloud integration instead of the JIRA Software server integration?

This JIRA Software Server integration used to work fine for both types of account instances but cloud instances may run into issues after this recent API update and so you may need to switch over to the JIRA Software Cloud integration going forward.

Userlevel 3

Hi Danvers,

thanks for the reply. At this time it is still not working. The JIRA users are still not showing up in the Zapier editor and therefore we still get an error when we run a test.

Unfortunately we can't use JIRA Software Cloud because the Zap Editor does not currently support some of the required fields. We tried that.

Userlevel 7
Badge +9

Hey @shwebteam are you able to confirm if you'r using a self-hosted version of the JIRA Software server integration or not? It sounds like we'll have to log this as a feature request but we want to make sure we've got our facts straight. Knowing the fields that aren't coming over would be helpful as well.

Let us know!

Userlevel 3

Hi @jesse ,

we are not using a self-hosted version of the JIRA Software server. The fields that aren't coming over are the ones containing the user: reporter and asignee. Even if you don't actually need to select a reporter, it seems JIRA still requires some data here. (and the format for that might have changed)

I don't understand why this suddenly would be a feature request when it was working 2 weeks earlier.

edit: I got a response from your support team that this seems to be a new / different issue than the one a few weeks ago and that an issue report has been opened.

Thanks for your help so far. If something new comes up or the issue has been resolved I'll post it here.