Best answer

Quickbooks Custom Fields are suddenly missing on invoices

  • 24 January 2022
  • 4 replies
  • 701 views

When in the testing phase I was using a copy of the production file in QBOnline, and everything worked smoothly interacting with CustomFields.  

But now that I’ve switched over to the production environment CustomFields are no longer available.  

I’ve tried deleting and recreating QBO app connections in addition to recreating the Zaps that use them to no avail.  

What changed such that these fields are no longer available via Zapier?

Please Advise,
Isaac

 

 

icon

Best answer by SamB 25 January 2022, 12:23

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

4 replies

Just recreated the original connection to the demo account mentioned above, and the original custom fields are showing again, but the production account’s custom fields are still not propagating through.  

Is this an issue with:

  1. How the original connection affecting how new versions behaviour (i.e. a schema that’s created upon an initial connection)?
  2. Or is this an issue with Quickbooks Advanced vs Pro versions of QBOnline (the demo is QBO Pro vs the productions use of Advanced, also the Pro connection was created first)?
  3. Do I have to create a new Zapier account/subscription to get rid of this behavior?

Need a solution or I’ll have to develop something in GCloud for this.  

Thanks in advance,

Isaac

 

 

Created a brand new and seprated zapier demo account, connecting directly to the production QBO file, and this is still an issue… so #1 or #3 doesn’t seem to be the issue above.  

Could there be a bug with Quickbooks Online Advanced, Zapier not supporting custom fields with this version?

Please advise,

Isaac

Looks like the issue maybe with backward/forward compatibility between version of QBO, namely Plus vs Advanced.  

https://help.developer.intuit.com/s/article/API-response-not-showing-existing-custom-field:

 

Article Body

A custom field will be shown in the API response only if:

  1. It is the first 3 String-based custom field configured in QuickBooks Online Advanced.
  2. It is enabled to all Sales forms(such as Sales Receipt, Invoice, Estimate, Credit Memo, Refund Receipt) or all Purchase forms.        

The mapping of the first three custom fields will be Immutable, i.e. even if the first three fields are marked as 'Inactive' in QuickBooks Advanced, they will still continue to be mapped in the API response.

For details refer to this link:
https://blogs.intuit.com/blog/2019/04/08/enhanced-custom-fields-quickbooks-online-advanced/

To verify this from QBO UI:

  • Login to the QBO Advanced account.
  • Go to Settings (Gear Icon) > LISTS > Custom fields
  • Toggle the button to 'Include inactive'.
  • Now, verify which custom fields satisfies all the above criteria and should be visible in the API response.

 

Those fields that get exposed to the API are only the first three created with type String, even if they get deactivated!

 

 

Userlevel 7
Badge +11

Hey @Isaac,

This is related the issue being discussed in this other thread: 


So I’m going to close this thread so that we can better track who is affected by this issue in the other thread. As you’ve already been added to the bug report mentioned on that other thread we’ll be in touch as soon as it’s been resolved. 🙂