Question

Private Slack channel does not populate in Zap - Need Help ASAP

  • 23 December 2020
  • 12 replies
  • 1170 views

Userlevel 1

Hi,

 

I am trying to create a automation where I want to post a message on the private slack channel.

 

The issue here is Zapier is not able to populate the private slack channels available in the workspace, while I see the public channels in the Zap. Can someone please help me ASAP


This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

12 replies

Userlevel 7
Badge +14

Make sure you are using the correct Slack Action

 

Userlevel 1

@Troy Tessalone Hi Troy,

Thanks for the response...yes this is what I have setup but still it does not show the private channels. 

Userlevel 7
Badge +14

Are you getting an error?

Check the Slack app connection here: https://zapier.com/app/connections

Perhaps provide a screenshot of what’s configured for that step.

Userlevel 1

@Troy Tessalone I  am not getting error as such, the channel field - the private channels are not getting populated at all! If I am selecting one of the public channels, then everything works fine

Userlevel 7
Badge +14

Can you please provide screenshots of how your Zap step is configured?

Userlevel 3
Badge +2

Hi , 

Yes, you can post a message to Slack private channel as well. for this, you would need to select  “Send Private Channel Message in Slack” Action event.
Userlevel 1

@sudesh @Troy Tessalone I have tried that, it does not populate the private channels at all. It only shows the public channels

Userlevel 5
Badge +5

Hey @Nisanta,

may I ask with which type of account your Slack is connected to Zapier? Type meaning member, admin, owner, etc. I was facing a similar issue once and I am wondering if it is related to that. Let me know!

Userlevel 1

Hi @Ennes,

 

I am the admin of the slack workspace

Userlevel 4
Badge +4

Hi @Nisanta,

A couple questions and thought of where the error might be:

  • Are you or your channels part of a team or is access given on a per user basis?
  • If you use a custom value equal to the channel ID instead of using the dropdown does the zap work?
  • Did you create the channels or did someone else create them?

I have also flagged this to Zapier as this sounds like a bug.  I ran a test in my account and my private channels were populated like they should.

Userlevel 7
Badge +8

Hello @Nisanta - We got the flag that this may be a bug, but I wanted to ask one more question that would help me file this appropriately. Is this channel a shared private channel between two external organizations?

Userlevel 7
Badge +8

Hi @Nisanta - It’s been a while but we wanted to check back on this issue. Without the details of my question, I’m unable to proceed with filing for the bug you’re reporting.

Please let us know how we may help!