Not able to connect to teachable account

  • 15 October 2020
  • 3 replies

the error am getting when i tried to connect Teachable account this is the error am getting - The app returned "You can't do that!".


Problem:: Zapier can't connect to your app account because your password was changed, or Zapier's access was revoked.

Solution:: reconnect your app account to Zapier.


I tried reconnecting but still its not happening.


This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

3 replies

Userlevel 4
Badge +5

Hi! My name is Justin and I write for the Zapier blog. Let’s see if we can figure this out together. 

So I looked into this and users sometimes get this error if they’ve changed domain names since setting up Teachable. Is that true in your case? If so try connecting using the domain name you originally used to set up your Teachable account. Weird, I know, but it should work. 

Hi, thank you for the feedback. No i havent changed any domain name. All the data is pulled out correctly only when am trying to test and continue it is giving this error. 

Am confused now how to proceed. 

Userlevel 7
Badge +10

Just checking in to see if you still need help with this?