Best answer

New GMail Attachment Print

  • 9 June 2020
  • 6 replies


I am brand new to Zapier and I am trying to implement the ‘New Attachment in GMail’ function, following it up by Submitting a Print Job in Google Cloud Print. When I run my test it seems to print fine but I when a mail arrives with an attachment nothing happens. I have my Zap turned on.

Could anybody maybe advise on something I may be missing?

Thank you.


Best answer by steph.n 12 June 2020, 01:14

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

6 replies

Userlevel 7
Badge +10

Hi @MauriceWhelan 

When you check here - - do you see anything listed?

Also, just in case you didn’t know, Google Cloud Print will shut down for good in December:

Hi @AndrewJDavison_Luhhu 

Thank you for you response. No there is nothing listed in History. I only want to print attachments of emails that have ‘EOD’ in the subject line. So should I put in just EOD or subject:EOD? Don’t think this is the issue, however, because it doesn’t seem to be working either way.

If I run the Zap manually it works.

Also thank you for the link detailing the closure of Google Cloud Print. I am aware of this, however, would you be able to advise of an alternative product that works the same way as Google Cloud Print and also has an existing integration with Zapier?

Thank you again.


Userlevel 7
Badge +10


I'm going to flag this post for the Zapier Community Team. They should have more insight on this and can escalate to the support team if needed.

Sit tight, and someone will contact you soon.


PS - As for alternatives, I’ve yet to find one :neutral_face:

Thanks so much @AndrewJDavison_Luhhu 

Userlevel 7
Badge +8

Hi @MauriceWhelan - Thanks for being patient! I just created a support ticket on your behalf. I sent you a response directly in hopes to obtain further information for our Support team. Please respond directly to that ticket to proceed further. Thank you!

Userlevel 7
Badge +8

Hey there @MauriceWhelan - It’s our pleasure to be able to connect with you. I’m glad that you were able to figure out how to make your reported Zap work again! To be mindful of others who wish to know how you did it, I’m sharing your answer here:

I think the issue I was having was not using the 'Subject' piece of the 'Customize Attachment' section. I am happy this ticket can be closed but I reckon I will have other queries in future as I explore the product 😀.
If you could recommend an alternative Cloud Printing Application that currently integrates with Zapier that would be great seen as though Google Cloud Print is shutting down shortly.
Thank you again.

As for your recommendation for an alternative cloud printing application, our Top Printing Apps may be found here:

Thank you so much again!