Best answer

Multiple FB Pages to Create Page Post



I have Inoreader set up to curate Facebook Page posts from numerous pages that are a members of our association. The RSS feed then triggers a ‘Create Page Post’ to share all of those posts to a single Facebook Page. 

I’ve had this set up for over a year and it worked beautifully at first. Whenever one of our members would post on their FB page, the zap would share it to our FB page, saving me tons of time manually sharing each of their posts. Over time, more and more of their posts are appearing on our page as a generic ‘’ link. When you click it, it takes you to the shared post, but the actual post does not appear on our page. All of our members’ posts are appearing this way, with the exception of one or two pages whose posts share perfectly. 

I’ve tried and tried to figure out what is different about the pages that work vs those that don’t, but can’t figure it out. I’m sure it is Facebook just being Facebook, but it’s frustrating that it used to work and now doesn’t. I can take the same RSS feed and embed it on my website and it looks perfect, just not sharing to a FB page.

Currently I check the FB page multiple times a day, click on any links shared, then manually share them and delete the link created by Zapier. Any suggestions on how to get this to work, or a better way to share posts from multiple pages automatically?


Best answer by ThatOtherMatt 27 January 2023, 22:15

View original

10 replies

Userlevel 7
Badge +11

Hi there @ThatOtherMatt, welcome to the Community! 👋

Are the links appearing correctly in the RSS feed items generated by Inoreader? If not then something may be going wrong the Inoreader side of things.

If the links are appearing correctly in the RSS feed items but are being changed in the post to then there’s likely an issue with the Create Page Post (Facebook Pages) action.

Can you take a look into some of the recent runs in your Zap History and confirm whether the links are coming over from Inoreader correctly?

Any screenshots you can share here to help show where the issue is occurring would be super helpful too. Please remember to remove or hide any private information like names, emails etc from it first.

Looking forward to hearing from you on this! 


Hi, Sam! Thanks so much for your quick reply! I will include several SS below of what I’m seeing, as I’m not up to speed on exactly what to look for.

1 - What is posted to our FB page:


2 - What the RSS feed looks like for the above post:


3 - What the RSS feed looks like for a post that posts correctly:


Thanks for your input!

Userlevel 7
Badge +9

Hey @ThatOtherMatt, just stepping in for Sam here and thanks for the extra clarity! From glancing at your screenshots, I am not seeing too much of a difference other than trhe contact of the post but a way to take a more granular look would be to use a tool like Diffchecker:

I’m also curious, if you took the same message content and same URL for a message that isn’t posting correctly, and posted it manually outside of Zapier, does it still show up as a generic Facebook link or does it unfurl? This might be “Facebook being Facebook” as you said, but let’s see if we can generate some evidence here to help pinpoint where exactly things are being constructed in a way that isn’t supportive for your workflow.

Keep us posted!


I’m also curious, if you took the same message content and same URL for a message that isn’t posting correctly, and posted it manually outside of Zapier, does it still show up as a generic Facebook link or does it unfurl? 

I’m not certain I know what you mean or how to go about this. Can you elaborate please? 

If it’s any help, I have the same feed embedded on our website, coming directly from Inoreader, and everything displays there perfectly.

Userlevel 7
Badge +11

Hi there @ThatOtherMatt

Ah I think what Jesse was asking is, if you were to post the same message directly through Facebook (not via the Zap) does the same thing happen (a generic Facebook link is shown) or does the link load a preview of the post correctly?

If it does load a preview correctly, then it could well be a bug with the Facebook Pages app. In which case you’ll want to reach out to our Support team to investigate further. They’ll be able to take a closer look at things and confirm whether it is indeed a new bug that’s popped up. Please do keep us in the loop on this! 🙂


Thanks, @SamB ! Through trying various things, here’s what I’ve discovered so far:

  1. Sharing the post using FB’s share button works perfectly.
  2. Sharing the post by pasting the url of the post to my page works, adds preview, etc.
  3. All posts from Page ‘A’ display perfectly, while all posts from Page ‘B’ are only the generic link. I’m wondering if this has anything to do with different page types??
    1. When clicking the generic link, it usually takes me to the intended post where everything is posted correctly, however, there are usually no share buttons. I need to click on the page name, then share the post directly from their page.

At this point, I’ve just come to conclude that it’s not possible to do what I’m attempting to do...except I’ve been doing it, and some of them still work! I don’t have much hair left & even less patience. May just need to accept that I will need to do it manually. I was hoping to figure it out soon before my Inoreader renewal comes up in case there is a better option for the RSS side of it.

I appreciate you guys looking into this and offering suggestions!

Userlevel 7
Badge +11

Thanks for sharing your findings here @ThatOtherMatt! 🙂

Hmm, as it’s working intermittently it could be a bug. Or it could be that there’s a difference between the links that are working and those that aren’t (permissions settings for the pages the link is going to perhaps?)

I’ve been doing some further digging on our end but couldn’t see any existing bugs related to this behaviour so I think your best bet here will be to contact our Support Team. You can reach them here:

Please do keep us updated on any solutions you may find! 


@jesse @SamB 

Amazing! Facebook finally gave me the option to switch my page (the one that is being posted to) over to the ‘New Pages Experience’. Since switching, everything has been working perfectly again! 

My conclusion is that it was indeed a Facebook issue. 😒

Thanks again to both of you for your input and suggestions!


...and now it’s randomly not working again. *sigh*

Userlevel 7
Badge +12

Hi @ThatOtherMatt!

Oh no, how frustrating! 

You might have some luck reaching out to the Zapier Support team using the Get Help form. The support team can really dig into your Zap with you and hopefully get to the bottom of things.