Best answer

Microsoft Teams Error: Number of requests inside batch exceed the limit

  • 20 September 2020
  • 15 replies
  • 309 views

Userlevel 1

I am trying to have an app update a Teams channel whenever a document is updated, but I am receiving the following error when setting up the zap.

“Number of requests inside batch exceed the limit”

We don’t have a large Teams account, but I did read a little about throttling. Any idea what is causing this, and how do we fix it? Do we need to upgrade our account to a certain limit?

Thank you for any help/advice.

icon

Best answer by Liz_Roberts 4 November 2020, 21:37

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

15 replies

Userlevel 7
Badge +8

Hi @kbunschoten4 ,

Sorry you’re encountering this error! As a first step, could you double-check that you have one of the following admin roles: Global Administrator, Security Administrator, Security Reader or Privileged Role Administrator within Teams?

If you do and that doesn’t seem to be the issue, you may need to reach out to our Support team so that they may investigate further in case there is a bug here!

Userlevel 1

HI Liz,

 

I’m a Global Admin. I will reach out to them, thank you.

Hi, experiencing same problem. Was this ever resolved ?

 

 

Userlevel 7
Badge +8

Hi there @kbunschoten4 and @Frank Mogensen - This is a bug. I have gone ahead and alerted our team in charge of this integration, so that they can review this issue further.

While I can't provide an ETA for when this issue might be resolved, we will reach out to you via email once it is.

Same here, any progress on this issue?

Userlevel 7
Badge +8

Hi @Wayne Goldstein - I am adding you as in impacted user to this bug report so that you will receive an email with any updates!

Hi there, any news on that one? Unfortunately, this also occurs when initially setting up a zap → Teams so we cannot even test for PoC. Would you mind adding me to the bug report, please? Thx!

Userlevel 7
Badge +12

Hi @Gru, we don’t have an update on this one yet, I’m sorry about that! I’ve added you as an affected user on this issue, which means that we’ll send you an email when we do have an update. 

 

Has this been resolved yet? This is really hindering my ability to complete some critical integrations.

Still waiting for this to be resolved as well

Userlevel 7
Badge +11

Hi everyone! I see an update as of 15 hours ago that this issue was addressed in the newest version of the Microsoft Teams integration. Can y’all check to see if there’s an updated version you can use, or if it’s now working with the version you’re using in your Zap(s)?

It’s working now

Userlevel 7
Badge +8

Hi All,

This issue you reported for the Microsoft Teams App has been fixed. When you are selecting your team in the dropdown in your Zap, you should see all of your teams, even if you have more than 20. Please reach out to Support should you experience any further issues with your Microsoft Teams Zap!

Userlevel 1

OK, I went to test this and it is saying the app is not installed for the Team. When I install the app, it says it is not a bot, cannot be replied to, etc. Shows in the App tab for the Team, but in Zapier says it has not been installed. I HAD HOPE! Any ideas? Would LOVE to get this zap working. Will be a big time saver.

Userlevel 1

OK, I went to test this and it is saying the app is not installed for the Team. When I install the app, it says it is not a bot, cannot be replied to, etc. Shows in the App tab for the Team, but in Zapier says it has not been installed. I HAD HOPE! Any ideas? Would LOVE to get this zap working. Will be a big time saver.

So update. I deleted the zap altogether and rebuilt it, and it THEN picked up the zap app in Teams. It did not detect it until we deleted and rebuilt the zap.