Question

Manychat Zapier intergration custom fields

  • 4 January 2021
  • 4 replies
  • 185 views

Hello,

I’m trying to integrate Manychat and Zapier to push data to Zoho CRM. I added few custom fileds such as first name, last name, email and company name. I ran the test chat on ManyCaht and verified the test user chat and collected the values in custom fields. When I try to integrate with Zapier for Zoho CRM. I setup trigger for custom filed email. When I test the trigger displays message: This custom field was found in your. Unfortunately when I see the details (all of the Zapier fileds), I notice non of the custom filed has any value. All custom filed shows as null. What I’m missing here? 

Because of this I’m not able to test trigger on custom fields. 

Thank for you help. 

Amjad


This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

4 replies

Userlevel 7
Badge +14

Be sure to reference the available help article:

https://zapier.com/help/doc/common-problems-with-manychat-on-zapier

 

Userlevel 7
Badge +11

Hi @zbizlink!

Would you be able to confirm which trigger you’re using in the Zap (it sounds like New or Updated Custom Field), and whether the person that shows up in your sample data actually does have data in one of the custom fields?

In other words, it could be the case that the field was updated to have cleared the value in the custom field, and that the trigger still caught that. 

So go to your sample data from the trigger, find the email address of the user then check in ManyChat to make sure you’ve got data in at least one of those fields. If not, can you see a revision history for that person, to see if something was removed from a custom field?

@nicksimard  I’m trying to set up trigger for New or Updated Custom Field on the custom field ‘Email’ address. I verified the chat for the same user and I can verify my custom fields were filled up from user response. But when I test the trigger, all custom fields are null in Zapier. Here is the output from Test Trigger: 

custom_field

id 5374303

caption Email

type text

description 

field_value null

user

id 3665479356847817

page_id 1742347786023835

user_refs

status:

active:

These fields are user information loaded for the current Zapier user account: 

first_name: TestFirstname

last_name: TestLastname

name: TestFullname

gender: male

 

These are custom field: Their values shows in Manychat response/chat history but inside Zapier no data.

custom_fields

Company: null

Email: null

firstname: null

LastName: null

Phone: null

Thank You,

 

This post has been edited by a moderator to remove personal/private information. For your privacy and protection please don’t post this kind of information in the Community. 

Userlevel 7
Badge +9

Hey @zbizlink - How are you getting on? Are you still having this issue? 

Have you tried putting through some more tests to see if there’s any variance across these?