Best answer

Mailchimp to Pipedrive Create New Contact failing to add the Organization

  • 16 June 2021
  • 8 replies
  • 96 views

Userlevel 1

Hi, 

I created a zap in order to automaticaly creat a new contact in Pipedrive whenever a new person is added to a specific MailChimp audience.

The zap is working as intended except for the organization part… All the other informations are in the Pipedrive contact but the organization. 

I also have a zap between gsheet and mailchimp with the same exact same informations and fields and here the organization is succesfully displayed

The question here is why with the same merge field from Mailchimp, the organization fields works with Gsheet but not with PipeDrive. 

If one of you already had the same issue or have any information about this issue, i’d be glad to talk with you :). 

I can provide further more informations if unclear or needed. 

Regards, 

 

 

icon

Best answer by Troy Tessalone 21 June 2021, 18:15

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

8 replies

Userlevel 7
Badge +14

Hi @Armis 

Please post screenshots of how your Zap steps are currently configured in order for us to evaluate further, thanks.

 

Do you have a specific example to use to trace and troubleshoot the data?

 

Zap app help articles:

Pipedrive: https://zapier.com/apps/pipedrive/help

Mailchimp: https://zapier.com/apps/mailchimp/help

GSheets: https://zapier.com/apps/google-sheets/help

Userlevel 1

Hi Troy, 

 

Thank you for the answer :) !

You will find down below screenshots of how this Zap is configured. 

 

 

 

 

As you can see with the last picture, the organisation is missing… 

It’s seems the “Merge Fields Mmerge 5” from MailChimp (which is th ecompany) is not working with Pipedrive. And, as mentioned at the first place, this same Mailchimp field is working with GSheet… 

Thanks for your answer :)

Userlevel 7
Badge +14

Hi @Armis 

Try troubleshooting by checking the triggered Zap Runs history details to see the DATA IN/OUT: https://zapier.com/app/history/

If there is no value provided for a data point from the Zap trigger step, then that would explain why the data did not map thru to Pipedrive.

 

Userlevel 1

@Troy Tessalone ty again for your answer. 

Here is what I found: https://zappy.zapier.com/e82f2da7f08c035a50d93d153cf73113.png

 

Not sure how to read that properly but it’s seems the organisation seems to be out from mailchimp and in to pipedrive but in the end it doesnt show off on pipedrive…

 

This post has been modified to remove personal information. Please remember to obfuscate any sensitive information prior to posting as this is a public forum. 

Userlevel 7
Badge +14

@Armis 

In the Pipedrive Zap step, the Organization expects the ID of the Organization in PIpedrive.

You may have to add a step before in the Zap to Find/Create the Organization, then map the ID to the Organization field in the Pipedrive Create Person step.

Give that a try and let us know.

Userlevel 1

@Troy Tessalone Well i tried but it’s not working… 

I created this in-between step in order to creat or find the organization before creating the contact. 

The orga is created but I am facing the same problem right after when the person is created : the orga is not attached to it even if created the step before… 

Maybe I configured the in-between step wrong ? 

Userlevel 7
Badge +14

@Armis 

The ID of the Org found/created needs to be mapped to the Org field in the Find Person step.

Check out this help article: https://zapier.com/help/create/basics/set-up-your-zap-action#set-up-your-action

Userlevel 1

It worked out !!!! 

ty a LOT Troy !!!!!!