Best answer

Jotform And HIPAA Zap issue

Userlevel 1

My Jotform form submissions are not showing any data in the fields. They are fully populated in Jotform.

Anyone have any idea why this is happening?

I have HIPPA turned on. Just recon

nected JotForm to see if that helped and have cleared cache too. Very confused.


Best answer by jesse 6 July 2020, 17:28

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

4 replies

Userlevel 7
Badge +7

Hi @RichardGibbons ,


Were these form submits made after you created the Zap? Or before? 
Zapier won’t find any form submissions which were made before you created the zap. Try to submit another form just before you hit the “Test” button.

Let me know if this helps you!



Userlevel 3

So I’m not the only one experiencing this issue with jotform

Userlevel 7
Badge +7

@RichardGibbons @kbeisly I just tried out one of our forms and it seems all working. Could you explain to me how you’ve setup the Jotform? And what kind of fields you are using? (maybe a screenshot of the form edit).

Also, please try to run the Zap workflow “live” so we can have a look if you do get this data when its live. Let me know!


Userlevel 7
Badge +9

Hey @RichardGibbons and @kbeisly, happy to help here!

Due to HIPAA guidelines, PHI (Personal Health Information) Protected fields will not be sent to Zapier when there are new submissions to HIPAA-compliant forms.

However, using JotForm's Protected Fields feature, you should be able to configure your fields to send response data to Zapier. PHI disabled fields will be still sent to Zapier.

Here is a help guide for Protected Fields feature:

I understand you mentioned having HIPPA turned on but I want to make sure you’ve done so in the correct spot. You can select this when authing Jotform in your Zap but you’ll also want to make sure you’ve enabled HIPAA compliance here:

If you’re still running into issues, the next best step would be to contact our support team using the form here: