Javascript Exception: `TypeError: Cannot read property 'contact_id' of undefined`

  • 27 August 2020
  • 9 replies
  • 701 views

Userlevel 1

This is the error im facing too. i have filled all fields and still unable to send my sales invoice to Zoho

 


This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

9 replies

Userlevel 7
Badge +11

Hi @Rahul mehra!

I split your topic from the one you’d commented on because the error message is a little different. What yours tells me is that you’ve mapped something into one of the fields that Zoho Books can’t process, or doesn’t understand.

To help us figure out what might be going on, can you share a screenshot of the Zoho Books step in the Zap Editor (please hide or remove anything sensitive). That should give us some clues about the source of the problem.

Thanks!

Userlevel 1

Hi, thanks for your quick reply. I have attached all screenshots. Do let me know in case theres something else that you want me to share.

Userlevel 7
Badge +7

Hi there @Rahul mehra ,

I haven’t used this Zap before, and I am not sure. But according to the Zoho API the contact_id is the unique identifier for the contact you want to create an invoice for. 

This makes me thinking, is the contact you are trying to create an invoice for in your system already? And is the name you are trying to assign it to the same as in Zoho? 

Hope this helps you.
~Bjorn

Userlevel 1

In the fourth screenshot, you can see that it mentions - if a customer name doesn’t exist it will create a new one. 

 

Userlevel 7
Badge +7

Ahh I see. Maybe you can verify this with some dummy data and see if that changes anything?

Remove all fields (copy and place somewhere to save) and then just put some dummy contact details.
I still think there is somewhere an issue there.

~Bjorn

Userlevel 1

I just tried that as well. No luck. It still shows the same error. 

I have the same issue. I have filled only the required fields and yet the same. Require immediate assistance.

Userlevel 1

@nicksimard could you please assist us. @Pranav bhas can you also attach screenshots so that this can be looked into?

Userlevel 7
Badge +12

 

 

Hi there!

Looking at the screenshots that you included, it looks like the issue is the way that the information has been added to the Customer name and Shipping charge fields. 

 

For the Customer name field, you should have only the name eg First name and Last name

 

For the Shipping charge field, you should only have the Shipping total, not the other fields

 

 

If you try that and are still having trouble, the best thing to do is to contact the Support Team so that they can dig into this further with you. You can do that using the Get Help form