Best answer

Is this error Zapier facing, or EDD facing?

  • 24 January 2020
  • 7 replies

Userlevel 3

I'm going through the standard motion of connecting Zapier with Easy Download Digital. The extension has been added and I can access it within Downloads -> Tools -> Zapier

(I have used the 2 setup documents provided by EDD, it doesn't have a fix for this problem).

The goal is to connect EDD with ActiveCampaign for better management of customer data.

Now, in Zapier, I have done the standard process in selecting Easy Download Digital as the first App, then it prompts me to add my API key and token and URL. After, I must hit the Test&Continue button. It. never. works. I've messed around with so many settings in wordpress to see if I can resolve.

The error displayed is: Got 417 calling POST, expected 2xx.

The URL I used when prompted is

There is not much in terms of support for this issue. I'm not sure why Zapier is having problems posting to EDD.

zapcommunityhelp.PNGAny help or input would be way more than appreciated.


Best answer by Addel 24 January 2020, 19:23

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

7 replies

Userlevel 7
Badge +10

Hi @Addel

So I had to look up a 417 error:

417 Expectation Failed Nothing helpful there.

Have you actually reached out to Zapier support about this? If so, what have they told you?

With triggers that connect into Wordpress, it almost always ends up being something to do with the connection being blocked by some configuration of your WP site or hosting... or a plugin conflict.

@Danvers - any insight?

Userlevel 7
Badge +12

Hi @Addel! It looks like Easy Digital Download is a private/invite only app, is that right?

Because of that, Zapier support will have extremely limited resources on the app and on the details of the integration.

To get the best help for your issue, I recommend you reach out to the folks who gave you access to the integration and see if they can take a look and see what the trouble might be. If you need any additional logs to pass to them, then the Zapier Support team will be the folks who can help you with that.

I'm sorry that we can can't offer more help here!

Userlevel 3

@AndrewJDavison_Luhhu @Danvers

Thank you both for commenting! So - EDD provides this setup document that just has a link in it to access a "private version" of EDD in Zapier. There is also a non-private version that appears (or atleast not labeled private) after doing so.

After clicking the access link within the document above, you will notice version 1 through 4 of EDD available on Zapier, plus an unlabeled version.

They all give the same error. The setup document shows EDD completing the Testing step within Zapier.

I've reached out to EDD support, didn't receive any information yet (been over 24 hours). Was hoping that someone here has built this connection before and has insight on the error.

Thank you for taking a look, though 🙂

Userlevel 7
Badge +12

I had another check and I can't see Easy Downloads listed in our app directory, so I think it's only available as a private app. Fingers crossed they'll get back to you soon!

Userlevel 3

EDD solved this issue.

in the url, for some reason it needs https:// rather than http:// (although it gives you strict instructions to use http:// and no trailing hash.

If anyone gets stuck in this situation, I hope this helps.

You think this would have been on a forum somewhere mentioned to try https haha.

Thanks everyone!

Userlevel 7
Badge +10


Oddly, I've had another client contact me today seeing the same issue, but they are using https:// in the URL. 🤔

I have the same problem and I am using https. But it still does not work…