Best answer

Is there a way to "create a spreadsheet row" in the last row available?

  • 24 January 2024
  • 6 replies
  • 122 views

Userlevel 1

I’m using a Form to send responses to a Spreadsheet with the “creat a spreadsheet row” option on, but it only sends the responses at the row 1, making everything else go down.

 

Is there a way to make it create this row at the bottom of the sheet?

icon

Best answer by Troy Tessalone 24 January 2024, 06:09

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

6 replies

Userlevel 7
Badge +14

Hi @thaduraes 

Which spreadsheet app are you trying to use?

If using GSheets, then reference this article: https://help.zapier.com/hc/en-us/articles/8496276985101-Work-with-Google-Sheets-in-Zaps

Userlevel 1

Hey Troy!

Yes, I'm using GSheets. Thank you for the article, there are a lot of rules I didn't know in there!

It's all good according to the article too, and I ran new tests but it keeps creating it a the top row (rows 1and 2 in the image below).

I'm sure there's something I'm missing here, but no idea of what it is.. Any other ideas? 

Userlevel 7
Badge +14

@thaduraes 

GSheet help articles: https://zapier.com/apps/google-sheets/help

 

Another option to explore is to use Airtable instead of GSheets, where you won’t have this problem because it’s a database app.

 

Symptoms

You've tried to add rows to the bottom of a spreadsheet, but the rows are instead being added to the top of the spreadsheet.
 

Causes

There are two reasons why this may happen:
  • Column A is missing a header: If Column A does not have a header, Zapier will not know how to interpret the data in the column and will assume that the data is all headers. As a result, when you try to add a new row, Zapier will insert it at the top of the column since that is where the headers are located.
  • Column A is being hidden: If Column A is hidden, Zapier will not be able to see the data in the column and will assume that the column is empty. As a result, when you try to add a new row, Zapier will insert it at the top of the column since that is where the empty cells are located.

How to fix it

To resolve this issue, follow these steps in Google Sheets:
  1. Ensure Column A has a header: If Column A does not have a header, add one. To do this:
    1. Select the first cell in Column A and type in a header name.
  2. Ensure Column A isn't hidden: If Column A is hidden, unhide it. To do this:
    1. Right-click on the column headers.
    2. Select Unhide Columns.

 

Userlevel 1

OOOOOH Ok! Problem solved then, I think! The column A was in fact hidden, I opened it just to print and show it has a written header.

Thank you so much, Troy! 

Userlevel 7
Badge +6

That’s great news @thaduraes! Big thanks to Troy for pointing you in the right direction!

If you have any other questions, please don’t hesitate to reach out to the Community. We’re always happy to help! 🤗

Userlevel 1

Thank you, Ken.a! Everything's working out really well right now. I'm new on zapier and I'm loving it!