Best answer

Importing Mailchimp 'Status' field

  • 10 March 2021
  • 2 replies
  • 71 views

Hi, I am trying to get my head around something here. 

 

I have set up a ‘Mailchimp Status’ column in Airtable to automatically provides the ‘Status’ i.e. “Subscribed”, “Cleaned”, “Unsubscribed” of an email address in Mailchimp. This way I can easily keep track of who in our database is currently receiving our mailouts, who has opted out, and which emails are bouncing.

 

I have a Zap set up which triggers when a subscriber is created or updated on Mailchimp. This in turn finds the corresponding record on my Airtable base and updates the ‘Mailchimp Status’ field with the ‘Status’ output data from Mailchimp.

 

So far so good, I have data appearing in my Airtable column. My issue however is that for some reason, instead of showing “subscribed” it is showing “subscribe”, and I can’t figure out why. When I am testing the steps in Zapier, the status output from Mailchimp shows as ‘subscribed’, but when it’s hitting my database in reality it is showing ‘subscribe’. 

 

This is obviously a minor issue and one that doesn’t affect the overall function of the Zap, but i’m keen to figure out why it’s happening. If anyone has any ideas or pointers on how to fix this please let me know.

 

Thanks

Tom

 

icon

Best answer by steph.n 11 March 2021, 01:20

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

2 replies

Userlevel 7
Badge +10

@tomadcock 

That’s definitely an odd one! 

I'm going to flag this post for the Zapier Community Team. They should have more insight on this and can escalate to the support team if needed.

Sit tight, and someone will contact you soon.

Userlevel 7
Badge +8

Hi there @tomadcock - Thank you for writing to us. As Andrew mentioned, this looks to be a flag for a bug. There’s inconsistency in the way that MailChimp is using the terms. It looks like it’s trying the “type” into “status” which is why you’re seeing the inconsistency in your output data.

I’ve gone ahead and reported this issue by adding your upvote as an impacted user. You’ll be contacted directly via email if/when we have an update to share. Thanks!