Question

How to use one form to fill out multiple forms (using Act-On)

  • 13 February 2024
  • 11 replies
  • 104 views

Hi Community!

When my team runs a webinar, we need a unique form for each date. This is quite frustrating for users when we run a series and they need to fill out 12 unique forms to attend the whole series.

Therefore, I am trying to use Zapier so that a user only has to fill out one master form which will then auto-fill the rest of the series.

My problem is, I can get one form to fill out another (using filters, so it doesn’t loop), but I can’t add any additional forms to the same workflow without huge loops happening, even if I use filters.

I thought then, maybe I can make multiple zaps using the same master form but the workflow in each zap fills out a different form - this way, when a webinar is done, I can turn off that zap and the form will no longer fill out that unique form.

But this also does not work, it seems that the first zap overrules the other ones I have built using the same form.

Does anyone have an idea how I can get this workflow working? I am using Act-On forms.

My ideal workflow:

 


This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

11 replies

Userlevel 7
Badge +11

Welcome to the Community @Mathilda! 🎉

I’d have thought that approach would definitely work for that sort of workflow. I wonder if there’s an issue with the set up of the filters across the different Zaps that is preventing the correct Zap from running based on the webinar they’d selected. 🤔

Can you share a screenshot showing the current filter conditions that have been selected in each of the Zaps that are looking at that “master” form? I’d like to take a closer look at them to confirm whether my theory here is correct.

Looking forward to hearing from you on this!

 Hi Sam,

Thank you, I feel like I’m going crazy haha!

I’ve screenshotted my last ill-fated attempt which used 50 zaps before I could turn it off.

1st: The full workflow

2nd, the filters:

Filter between master form and form 1

The field in form 1:

Filter between form 1 and form 2 

The field in form 2:

It seems to work fine in the first step, but when I add the third form, it doesn’t work.

Even when it works, it submits form 2 twice.

Do you have any insight into what might be breaking?

Thank you for your help!!

Hi Sam! Thanks for your help. I tried to respond but my response is being held by moderators so I will try again :)

Here is my full workflow for the “one form fills out multiple” idea:

My first filter will only continue if one of the form fields does not contain #ET93 - I added this to the field in Zapier so that any time it goes through the process, it adds that #ET93. It also has an ‘OR’ condition, where it will only continue if the form field does not contain #AB1.

My second form has #AB1 added by Zapier when it goes through this process.

 

Userlevel 7
Badge +11

Thanks for getting back to me @Mathilda. Not sure why the previous post was held for approval by the system but I’ve approved it now - sorry for the delay on that! 

Ah, it looks like you’re attempting to add all the filters for each webinar form within a single Zap instead of multiple Zaps - I think that’s why it’s submitting the form twice as it passes both of the filters and runs a form submission action.

The actions to add the filters and form submission for each of the different webinar forms would need to be put in multiple Zaps, not held within a single Zap (unless you were using paths instead of filters). For example:

Zap 1 - Adds a submission in form 1

  • Trigger: New Form Submission (Act-On) - triggers when the “Master form” receives a submission.
  • Action: Only continue if (Filter by Zapier) - checks if Spare 2 field (Text) Contains the word #AB1
  • Action: Create Form Submission (Act-On) - submits the details from the trigger to Form 1


Zap 2 - Adds a submission in form 2

  • Trigger: New Form Submission (Act-On) - triggers when the “Master form” receives a submission.
  • Action: Only continue if (Filter by Zapier) - checks if Spare 2 field (Text) Contains the word #AB2
  • Action: Create Form Submission (Act-On) - submits the details from the trigger to Form 2


Zap 3 - Adds a submission in form 3

  • Trigger: New Form Submission (Act-On) - triggers when the “Master form” receives a submission.
  • Action: Only continue if (Filter by Zapier) - checks if Spare 2 field (Text) Contains the word #AB3
  • Action: Create Form Submission (Act-On) - submits the details from the trigger to Form 3


Zap 4 - Adds a submission in form 4

  • Trigger: New Form Submission (Act-On) - triggers when the “Master form” receives a submission.
  • Action: Only continue if (Filter by Zapier) - checks if Spare 2 field (Text) Contains the word #AB4
  • Action: Create Form Submission (Act-On) - submits the details from the trigger to Form 4


Zap 5 - Adds a submission in form 5

  • Trigger: New Form Submission (Act-On) - triggers when the “Master form” receives a submission.
  • Action: Only continue if (Filter by Zapier) - checks if Spare 2 field (Text) Contains the word #AB5
  • Action: Create Form Submission (Act-On) - submits the details from the trigger to Form 5


​​​​​
We have a guide that talks about how to create this kind of branching logic using multiple Zaps and filters that you might find helpful: Add branching logic to Zaps with filters.

In the filter you’ll need to use the (Text) Contains rule condition, not the (Text) Does not contain condition. Using the Contains rule condition would ensure that out of all the Zaps that trigger for the same form submission only one Zap would run. You can learn more about Filter and path rules in Zaps here.

Can you give the above suggestions a try and let me know if that gets helps to sort it? 

HI @SamB!

Sorry for the delay in my response, but I have tested what you’ve suggested above, and I still can’t get more than one zap using the same ‘master form’ to work 😭

I don’t fully understand your point about using the ‘text contains’ rather than ‘text does not contain’ - if I use this filter, nothing comes through. When I was using the ‘does not contain’ filter, I was adding the “#AB1” manually, e.g.:
 

If I don’t use the ‘text does not contain’ filter, then the zap loops and if I change to ‘text contains’, then the zap is filtered out before it can trigger the webinar form. I cannot add any prefilled content in the original form unfortunately.

I’m still having the issue where my first zap works fine but the second zap does not trigger the 2nd form.

Both zaps are built the same (except the filter which is #AB1 for Zap 1 and #AB2 for Zap 2) - and the tests seem to work, just not the actual submission. I’m not sure how this next screenshot will look:

I have checked that the webhooks are listed in Act-On, and everything looks good there too.

Thank you for your help, I really appreciate it!

Userlevel 7
Badge +11

Thanks for getting back to me @Mathilda

Using the filter condition of (Text) Contains is correct as you’d only want one of the Zap to run if it finds a match and submit the form submission to the relevant form.

For example, if you had 5 Zaps all checking that the Spare 2 field does not contain “#AB1”, then Zap 2, Zap 3, Zap 4 and Zap 5 and add the submissions for Form 2, Form 3, Form 4 and Form 5 instead of Form 1. But if the filters are checking that the Spare 2 field contains “#AB1”, then only Zap 1 would run and add a submission to Form 1.

I think part of the trouble is that we’re not seeing any value come through for the selected Spare 2 field when the Zap runs live:
f74b2d4ef0ce962ca24aec9541fc87ef.png
or when a test record comes through in the Zap:

7dbb41fb915d8628a9de415702a97a34.png
And because of this the filters can’t find a match for those keywords in the Spare 2 field (#AB1 etc.)

Can you confirm whether there’s definitely a value in the Spare 2 field that should be coming over to the Zap when it runs for new form submissions? Or is there a different field on the master form that contains a value like #AB1 that would indicate which webinar the submission relates to?

Looking at the set up of the Create Form Submission action it appears that the master form may have been selected instead of the Act-On form that relates to the specific webinar. As it says “One form for all IFRS forms...”:
98920c69aedf076ebcfdc90a998fa6ef.png

If that’s the master form can you try selecting the specific webinar form instead and then test that action to check it submits a form submission to the correct form? 

 Hi @SamB ,

Thank you :)

Yes, I was adding the #AB1,2,etc manually so once the form was triggered, it would add this ‘code’ into the spare 2 field which would stop it from running twice.

As this was a test, I was being lazy and not renaming my test forms, so the original form is ‘One form for all IFRS forms (INTERNAL ONLY)’ and then the next ones are the same but with ‘(copy)’ or ‘(copy) (copy)’ - but the data is going into separate lists with separate automatic actions, so they function as their own unique forms.

I have now tried with a new master form and new ‘child’ forms, and am still having an issue where one zap will trigger and the other won’t.

My new zaps are using completely separate forms, built separately. When I test the connection, everything works, but when I fill out the form and try to trigger the zap only the first made zap will trigger.

If I edit the first made zap to change the filter so it triggers the 2nd webinar form, it works, so I don’t know if it’s a build issue. 

I think I have found a potential issue which is that Act-On forms can select multiple webhooks, but it seems only one actually works (the circled one seems to be the only webhook that actually triggers):

Have you seen this issue before? Is it potentially something I need to raise with Act-On?

Hi @SamB, my response has been held by moderators again 😭 Maybe because of the screenshots

Userlevel 7
Badge +11

No worries, @Mathilda I’ve approved your post now. Sorry your posts with screenshots attached keep getting flagged for approval, the system is being a bit too overly cautious!

Ah, I see! Thanks for clarifying that, it sounds like you’ve got them set up correctly then. Nice work! 🙌

Hmm, I’ve not come across that issue before with Act-On. I’m guessing those webhooks were created automatically when the Zaps were linked to the same form and the first one is overriding the rest of them. Does that working webhook also appear in the Outgoing Endpoints field?

If not, can you remove it and add it into the list of webhooks in that Outgoing Endpoints field:
ea611079a965335bdc662309cb21847d.png

Otherwise, if it’s already in that field can you just remove it from the Post the data submitted on this form to the following external URL field? So that only the Outgoing Endpoints field contains the webhooks.

Then try submitting the master form again to see if all the Zaps are then able to trigger for the same form submission.

Please do keep us updated on how you get on with that!

Thanks @SamB, no screenshots this time, so should be smooth sailing 😊

I have tried to remove the webhook from that area - the secondary area has the right webhooks applied, and now both zaps are not triggering. I think this is the issue.

I set both/all of these webhooks up in the Act-On connector settings and gave them full access, so they should trigger. Act-On is sunsetting their classic form type and rolling out this new form type, so it might be that they have not considered the impact or it’s an early bug.

I will reach out to them to see if they have any answers! Thank you for all your help, if you have any other troubleshooting you think I should try, I am all ears 😊

Userlevel 7
Badge +11

Thanks for giving that a try @Mathilda. Hmm, yes I think you could well be right on that! 

If they’re not able to provide a fix there is a workaround that you might want to explore:

Essentially you’d have one Zap that triggers for the form submissions that uses a Webhooks by Zapier action (added before the filter action) to send a webhook with the form submission data to multiple Zaps. So you’d likely need to move that webhook back into the previous field so it’s able to trigger again. Then in the other Zaps that currently aren’t triggering you’d use a Catch Hook (Webhooks by Zapier) trigger instead to get all of them to trigger for the same form submission.  

 
If you do give that a try and run into any issues let me know, keen to help get this up and running. 🙂