How to stop "Your Zap was turned off" and error messages when there's no actual error?

  • 10 January 2023
  • 2 replies

Hey everyone! 


I have two Zaps set up to take information from our Airtable CRM and push each contract to mailchimp (email) and SimpleTexting (SMS).


There’s many scenarios where we add someone in our Airtable CRM who only has one of the two; either only an email or only an SMS.


I keep getting “error” messages when one of those fields are blank on airtable. For ex, If i add “Bob Smith” and his email “” but don’t put any phone number, I’ll get a Zapier error because, of course, there’s nothing for Zapier to pull from the CRM to input into Simpletexting.


This isn’t actually an error - I just want Zapier to pull that info and push it to the respective app WHEN THERE IS something there. This wasn’t a problem until now because I just muted the “error” notifications from Zapier. But I just got an email showing “Your Zap was turned off” (see below) because of all the “errors”


What can I do to fix this? Every time I try to turn the Zap back on, it automatically turns off. But there aren’t real errors!! Help!



This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

2 replies

Userlevel 7
Badge +14

Hi @Hello World 

Good question.

Try this...

Create 2 Zaps each with a Filter: 1 for email exists, 1 for phone exists.

Or you can use 1 Zap with Paths if your Zapier plan allows Paths.

Userlevel 7
Badge +8

Hey @Hello World 👋, this page may be really helpful for you. If you’re not on a Team, Pro, or Company plan, you can scroll down towards the bottom and checkout the info for Zapier App Manager. Let me know if this or Troy’s recommendation’s help!