Question

How to reply to a response on Gmail ?

  • 8 February 2024
  • 3 replies
  • 16 views

Hi zap’ community, I need your help.
 

I want to create a zap:
When I write “it’s done”, it’s that everything work.
So I would like to this zap :

1/ I receive an email on Gmail (it’s done)
2/ I create a response prompt openai (it’s done)
3/ The client receives a response (it’s done)
4/ The customer responds to the email (not working)
5/ The client receives a new response (not working)
6/ Do it to the infini (not working)

Would it be possible to receive help?

Thanks lot for your help.

 

Johan.


3 replies

Userlevel 7
Badge +6

Hi there @Bigjo,

Welcome to the Community! 🎉

Before we dig deeper into this, would you mind sharing a detailed screenshot of how your Zap is configured? Also, please share a screenshot of the “Action” section of your action steps that shows all of its fields. Like so:

46dd6c0979e3d815d621b8da43084ef1.png
(view larger)

Please don't include personal information in the screenshot, or be sure blur out any personal information.

Thanks!

Hi !

Thanks for your answer !
Here is my zap with step 4 (find a new mail) and with my step 5 (reply again).

My step 4 to find a new mail
The “thread id” is the same that my original discussion.

 

My step 5 to reply to discussion
The “thread id” is the same that my original discussion.
The “from email” is the sender mail

 

Here is the end of my step 5 to reply a discussion
The “from” is my business email.
The “from name” is my company name
The “body” is my ia prompt.

 


So the goal is to send a new reponse when customer reply again on the same gmail discussion.


Thanks for your help !! Really.

Userlevel 7
Badge +6

Hi @Bigjo,

It looks like you’ve reached out to our Support Team about this and they replied today with a suggestion. I’ll share details of the suggestion here in case it’s helpful:

Based on the information you've provided, I understand that you're having trouble getting the bot to respond to customer replies. I'd be happy to help you troubleshoot this issue!

To start, let's ensure that your Zap is set up correctly. Here are some steps to follow:

1. Please check if your Gmail trigger is set to 'New Thread'. This ensures that the Zap is triggered when a new email thread starts, not just with every new email. 

 
(Click here to view larger)
2. Ensure that your 'Send Email' action in Gmail is properly configured. Here, you need to make sure that you're pulling in the right data from the email thread that you want to respond to.
3. Test your Zap to verify that everything is set up correctly. 

Please try these steps and let me know if you continue to experience any issues. If you're still having trouble, it would be helpful if you could provide screenshots of your Zap setup. This will allow me to better understand your configuration and provide more targeted assistance.

If you’ve got any questions regarding their suggestion it would be best to continue the conversation with them over email. If you can’t locate their reply I’d recommend searching your spam/junk folder or searching your inbox for any emails from zapier.com in case. Sometimes their emails can end up in the spam/junk folder by accident.

Reply