Question

How to remove companies from a LinkedIn Ads Matched Audience using Zapier?

  • 8 April 2024
  • 8 replies
  • 92 views

Hi there! About the integration with LinkedIn Ads to create Matched Audiences, is there a way to Remove Companies as well, apart of Add Companies in an audience?

Thank you so much!


This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

8 replies

Userlevel 7
Badge +14

Hi @grow2b 

You would likely need to use this advanced Zap action: API Request

 

Hi @grow2b 

You would likely need to use this advanced Zap action: API Request

 

Hi Troy! I have tried to do this, but I can’t. Somehow this is returning an error.

Any clue about how I can do it?

Thank you so much!

Userlevel 7
Badge +14

@grow2b 

We would need to see screenshots with how the Zap step is configured in EDIT mode along with the encountered error to have context.

@grow2b

We would need to see screenshots with how the Zap step is configured in EDIT mode along with the encountered error to have context.

Thank you so much, my friend!

As you can see, here is a screenshot of the custom action I have made.

The last image is related to the test, that is returning:

{
    "result": {
        "request": {
            "method": "POST",
            "url": "https://api.linkedin.com/rest/dmpSegments/22036623/companies?q=account&account=urn:li:sponsoredAccount:509269075",
            "querystring": null,
            "headers": {
                "Content-Type": "application/json",
                "LinkedIn-Version": "202403"
            },
            "body": "{\"action\":\"REMOVE\",\"companyName\":\"Teste\",\"companyWebsiteDomain\":\"{{companyWebsiteDomain}}\",\"companyPageUrl\":\"{{companyPageUrl}}\"}",
            "data": {
                "action": "REMOVE",
                "companyName": "Teste",
                "companyWebsiteDomain": "{{companyWebsiteDomain}}",
                "companyPageUrl": "{{companyPageUrl}}"
            }
        },
        "response": {
            "status": 400,
            "headers": {},
            "body": "{\"status\":400,\"code\":\"ILLEGAL_ARGUMENT\",\"message\":\"Resource method could not be resolved from request parameters.\"}",
            "data": {
                "status": 400,
                "code": "ILLEGAL_ARGUMENT",
                "message": "Resource method could not be resolved from request parameters."
            }
        }
    }
}

 

Userlevel 7
Badge +14

@grow2b 

Check the field description.

Try using remove as all lowercase.

 

@grow2b

Check the field description.

Try using remove as all lowercase.

 

Hi Troy!

Even with lowercase, it didn’t work… :(

 

{
    "result": {
        "request": {
            "method": "POST",
            "url": "https://api.linkedin.com/rest/dmpSegments/19665073/companies?q=account&account=urn:li:sponsoredAccount:509269075",
            "querystring": null,
            "headers": {
                "Content-Type": "application/json",
                "LinkedIn-Version": "202403"
            },
            "body": "{\"action\":\"remove\",\"companyName\":\"D\",\"companyWebsiteDomain\":\"\",\"companyPageUrl\":\"https://www.linkedin.com/company/597387\"}",
            "data": {
                "action": "remove",
                "companyName": "D",
                "companyWebsiteDomain": "",
                "companyPageUrl": "https://www.linkedin.com/company/597387"
            }
        },
        "response": {
            "status": 400,
            "headers": {},
            "body": "{\"status\":400,\"code\":\"ILLEGAL_ARGUMENT\",\"message\":\"Resource method could not be resolved from request parameters.\"}",
            "data": {
                "status": 400,
                "code": "ILLEGAL_ARGUMENT",
                "message": "Resource method could not be resolved from request parameters."
            }
        }
    }
}

Userlevel 7
Badge +14

@grow2b 

Make sure all your test inputs are valid values and in the right format.

 

Using app APIs is an advanced approach.

The AI Custom Action builder can result in invalid generated API requests as that is still a beta product.

 

You may want to consider hiring help from a Certified Zapier Expert: https://zapier.com/experts

Hi @grow2b 

I was facing a similar issue and wanted to check if you were able to find a resolution for this?