Question

How to extract specific custom field data from Cvent using Zapier?

  • 4 December 2023
  • 7 replies
  • 107 views

I’m attempting to pull information from a custom field in Cvent, and Zapier is able to pull the applicable ‘Custom Fields ID’ - but how can I take ONE of the IDs in the list to pull for a specific field in Zapier? For instance, the first ID listed below is associated with the ‘Program Name’ - but is there anyway to parse that FIRST ID consistently?

 Sorry if this is a bit a bit basic of a question - thanks!


This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

7 replies

Userlevel 7
Badge +14

Hi @evelder 

Good question.

Can you post screenshots with how the Custom Fields are returned from Cvent so we can see the structure of the data?

 

This related article might be helpful.

 

Cvent returns the data via a few different line items, seen below. Not pictured is the ‘Custom Fields Value,’ which includes the answers to the ‘Custom Fields Name’ questions that a given form is answering.

 

Userlevel 7
Badge +14

@evelder

Check out the related article.

 

Hey Troy,

Finally getting around to testing this out.

The information sent from Cvent is separated by commas, but the information being submitted via Cvent also contains commas, which is resulting in the output information being not separated out correctly, I believe. If I attempt to run the Text to Line-item on the ‘question’ portion of the event on Cvent, it outputs each item correctly, but running the same utility function on the ‘answer’ portion is resulting in an incorrect result with only about 4 very large outputs when there should be ~16. I’m not sure if this means its a dead-end or not for getting this to work?

Userlevel 7
Badge +14

@evelder 

We would need to see screenshots for context with how the Zap steps are configured and the data input/output.

Attached are the screenshots for how the information is being parsed - hope this helps explain the current issue I’m running into. Conversely, the conversion will work correctly on the ‘question’ portion of the query, also attached.

Userlevel 7
Badge +14

@evelder 

The screenshots are cutoff and don’t include enough context about which step # for the Formatter steps.

Did you try following the same concept as outlined in this help article?