How to enable all required AI Actions in a single configuration link on Zapier?

  • 16 November 2023
  • 4 replies

Starting with these instructions, I modified these with extra actions required for a custom gpt, but each action gets displayed as it’s own link to add separately. 

“It seems that the necessary Zapier AI Action for retrieving your agenda from Google Calendar is not currently enabled. To access your agenda, you'll need to enable the "Google Calendar Find Event" action. Please use this [configuration link]( calendar find event&setup_params=set have AI guess for Start and End time) to set it up. Let me know once you've done this, and I can proceed with checking your agenda for today.”

Last night I was able to get it to display a list of links I need to click and enable each ai action separately. Is there a way to get the configuration link to add/display a list of all permissions needed so you can do this one time and be done? 

4 replies

Userlevel 7
Badge +11

Hi there @nMile, welcome to the Community!

Hmm that’s odd. If you’d already set up and enabled that action then it shouldn’t be asking you to do that again. I’d recommend reaching out to the AI Actions team to investigate this further. It may be that you’ve stumbled across some sort of bug! You can get in touch with them directly using the form here:

Sorry to not have a workaround of immediate solution to provide here. Please do let us know how you get on with them, keen to ensure this gets resolved! 🙂 

Hello! Thank you for the reply! 

So I started with the example instructions, and once my gpt has the “find event” action enabled, it seems to keep it. But I’m wanting to build these to be available to other users, and as it sits now, they’d have to click 6 separate links and enable one action at a time. Is there a way to have them click one link and enable all required permissions at once?


Also I just tried to submit a ticket and after hitting submit it displays a gray box that says “ refused to connect.”

Userlevel 7
Badge +11

That’s great news @nMile! Thanks for letting us know that after following the example instructions allowed the “Find Event” action to stay enabled. 😁🎉

I’m not 100% certain whether it’s possible to have a single link clicked to enable all the required permissions for each action but I’d expect it’s not. The Support team that are handling queries regarding AI Actions would be able to confirm whether it’s definitely possible or not. And they’ll be able to open up a feature request for that if it’s not currently possible.

I’ve just tested the form myself and got the same error. I was able to find your submission as well as my own though so it appears that the submissions are going through correctly. Despite it showing that “ refused to connect” error.

Someone from the team will be in touch as soon as possible, thanks for your patience in the meantime.