Best answer

How do I schedule daily emails using Zapier Delay after the Pipedrive Activity Matching Filter?


Userlevel 1
Badge

Hi

I have been racking my brain over this all week and have not had a n answer from Zapier on why this is the case.

I want emails to go out at a certain time each day.  I cant use “Schedule by Zapier” as the filter is an Activity Matching Filter from Pipedrive and the option is not available if I use Schedule. So I need to use Delay

I want to send an email to all matching filter items from Pipedrive. Retrieving hte data from pipedrive is working fine. 

I’ve set the Delay to various times, in this case, 12:15 PM –  however the emails keep getting sent immediately after i create the Activity in pipedrive.

Can I please get some help with this.

My timezone is set correctly to Australia / Sydney

 

I’ve attached the Zap, the Delay Setting and the emails screen showing emails are being sent straight away not delayed till the Delay Time

 

Any help would be really appreciated as been on this all week.

 

Thanks in advance

Paul

 

 

icon

Best answer by paula_gfs 14 May 2024, 23:04

View original

5 replies

Userlevel 7
Badge +11

Hi @paula_gfs, welcome to the Community!

I did some digging into this and discovered a bug where the Delay Until action will use the date in system timezone (UTC) if no date is specified. I wonder if that might be what’s causing the issues here. 🤔

Can you try adding a date alongside the time value in that Delay Until action and let me know whether that gets the email sent out at the correct time? 

If it does then I’ll get you added to the bug report. Looking forward to hearing from you!

Userlevel 1
Badge

Firstly - thanks @SamB for tyghe welcome (and of course the response 😀) 

 

I wanted this to run daily so did not want to put in a specific date. I agree with you, that I also beleive it’s a UTC issue, although my tiumezone is set correctly to Australia, Zapier does not look at that when times are entered. That surely is a bug as any user will expect to be entering a local time not a UTC time.

 

In anycase, after trial and error, I changed the time to read exactly like this:

 

“Each day at 4:15 pm Sydney Time”

 

And this seems to work well.

If i write “Daily at 4:15 pm Sydney Time” that does not seem to work. Strange!!!

 

In anycase really appreciate the time you took to answer this and offer to raise a bug. I still beleive it’s a bug :)

 

Thanks again

Paul

 

Userlevel 7
Badge +11

Thanks for getting back to me @paula_gfs!

I know Date/time fields can accept certain formats like today, tomorrow, next Monday etc. but I wouldn’t have thought that “each day” or “daily” would work. I wonder if “Each day” worked because it was interpreted as “today” perhaps? At any rate, I’m super pleased that setting the delay until time to be “Each day at 4:15 pm Sydney Time resolved things for you here! 😁

I’ve gone ahead and added your details to the bug report. I can’t make any promises around when it will be resolved by but we’ll be sure to send an email notification to you here as soon as it is. 

If there’s anything else you need some assistance on just let us know. In the meantime, happy Zapping! ⚡

Userlevel 1
Badge

Thank you again @SamB 

Userlevel 7
Badge +11

You are most welcome, @paula_gfs! 🤗 

Reply