Best answer

How do I fix (#100) Page Public Metadata Access requires either app secret proof or an app token on my zaps?

Userlevel 1

I cant turn on my zaps because of this issue: (#100) Page Public Metadata Access requires either app secret proof or an app token


Best answer by Danvers 29 April 2020, 17:32

View original

24 replies

Userlevel 7
Badge +8

Hi @iBAN ,

Thanks for reaching out and sorry you are running into this error! It sounds like you’re running into an access issue that may be due to current permission settings. 

Can you share what apps you are trying to connect (sounds like a social media page)? That will allow us to dig deeper and get you squared away!


Hi, I am facing the same issue. It's related to Facebook lead gen ads.  Please help

Userlevel 7
Badge +12

Hi there @Pranayg93 and @iBAN! If you’re using Facebook Lead Ads, it has a lot of different permission settings, and if one of them isn't correct it will stop new leads from being passed to Zapier.


Even if you’ve previously set up a successful connection with Zapier, something can change and you’ll need to reset those permissions. Could you please take a look at this help guide and work through all of the steps there to see if that solves the issue. 


@iBAN if you’re using a different app, could you let us know? Thanks! 

Hey guys.. I’m having the same exact issue on 3 zaps I have setup with the same ad account and fb page. It had been working fine for over 6 months at least and just stopped all of a sudden on 3/18/20. I have all admin permissions, tried reconnecting several times but seem to still have the issue.. Any advice? Thank you..



Userlevel 7
Badge +12

Hi @bryanjlaz thanks for your message and I’m sorry that you’re having this issue with your Zaps. Can I double check with step of the Zap you’re seeing an error with? The message ‘(#100) Page Public Metadata Access requires either app secret proof or an app token’ is one that we’re seeing with Facebook Pages (rather than Lead Ads). Could you confirm that so we can be sure that we’re on the same page? Thanks!

Hi guys, I’m facing the same error with my Facebook Page that is connected with Zapier. I’ve tried reconnecting the Facebook Pages on Zapier and resetting the connection with Facebook. But still receiving the same error. What should I do? Please help… 

Userlevel 1

@Danvers - I too am having the same problem. 

Summary: I setup 


Here’s a walk-thru of me setting it up. There is NO SOUND.


My permissions:


What can I try?

Userlevel 7
Badge +12

Hi @hivehero and @CSS! Issues like this are really tricky to trouble shoot via the community as they generally need someone to take a close look at your Zaps and permission settings in Facebook.


The best thing to do here would be to send as many details as possible to the Support Team using the contact form. I’m sorry to send you somewhere else, but the Support team will be able to dive into this with you to find out if it’s related to the set up of the Zap/permissions in Facebook or if it’s something else. 

Userlevel 7
Badge +12

Hi folks! I wanted to post an update to let you know that we’ve investigated this bug and it looks like it’s resolved itself. Just to re-iterate, this bug is where folks are using Facebook Pages and having trouble finding samples and specifically see the error (#100) Page Public Metadata Access requires either app secret proof or an app token

I’m still having this issue right now on many of my Zaps

Userlevel 7
Badge +11

Hi @ChoiceLocal!

I see that you’ve written to our Support team and they have responded with some questions. Please continue the conversation there, since they’re able to dig into your Zaps :)

Is there any zapier technical support email or phone number that I can call? 

I’ve been having this same issue for days and really need it fixed urgently.

Any article will help, but couldn’t find any.


It was working perfectly for a whole year and suddenly today this shows up as I’m trying to customize my lead:

  • (#100) Page Public Metadata Access requires either app secret proof or an app token


Userlevel 7
Badge +12

Hi @kamilla, I’m really sorry that you’re running into an issue with your Facebook Zap. I can see that you got in touch with the Support Team and that they’ve already got back to you. It’s best to continue the conversation with them via email as they’ll be able to take a closer look at your Zap with you. 


If for any reason that you can’t see our email to you, please could you check your spam folder and if that doesn’t help, please try searching  your whole email inbox for emails ending in ‘’

@Danvers thanks for your reply.


I haven’t received any reply from Support Team other than the “Thank you for activating your Zapier Community account!” email.

I have checked spam as well.

If there was an email sent to me with the reply, would you please ask the support team to resend it?

Thank you!

@Danvers never mind! just found it. thanks!

Userlevel 7
Badge +12

@kamila Perfect, thanks for letting us know 🙂

ERROR: (#100) Page Public Metadata Access requires either app secret proof or an app token

How to troubleshoot this?

Userlevel 7
Badge +8

Hi @crown ,

Thanks for reaching out- sorry you are encountering this error!

You have stumbled across a current bug with the Facebook Lead Ads integration. I have added you as an impacted user, so once resolved you will be notified. 

As a workaround, here are a couple things to try:

  1. Disconnect Zapier from your Facebook Business Integrations


  1. Once that's done, go back to your Connected Accounts page - - and click Reconnect on your Facebook Lead Ads Account. Then see if your page shows up.

It also can't hurt to double check you have all the permissions listed here, and have a look at other help topics on this page, which is about the most comprehensive help page we have for any app on Zapier.

Let us know if those do the trick!

(#100) Page Public Metadata Access requires either app secret proof or an app token


Hi it look like im the only latino here, so im gonna take the time to write it down for people in spanish to. 


I have all the permissions that everybody said, I have 8 accounts and I have never had this problem before, the platform tends to make changes (facebook) pretty often, and the thing is that I have to delete everything and start from the scratch 5 times, check over and over again every single permission and the error remains, as a third-party app they obviously will not help you with Facebook cuz Facebook it doesn´t belong to them, and here I am and I don´t have anything to try but to ask the owner of the account to give myself permission throw the LEAD ACCESS WICH I HAVE NEVER TRIED IN THE PAST, SO THE WEIRD thins is that i have never been forced to do that, my steps to create an ad account for the client is

-create with their email

-give myself an admin permissions 

-Assign myself as a partner with admin pemissions

-An for now i have to wait till mondoy to entrer to the creator account and explore the partnerships permissions 



Para los latinos, le problema parece ser que aumento la seguridad en la arte de lead access por lo que tienen que entrar a la cuenta administradora creadora de la cuenta y asignar el business manager como socio con permisos de asministrador, o al menos eso es lo que voy aintentar por que fuera de eso literalmente no hay nada, revisen sus permisis a nivel pagina y cuenta publicitaria en ambos casos deben tener accesos como administrador 


The problem isn’t resolved. I double-checked all the rights from Facebook Business manager and ad account manager side, reconnected the accounts, but I still can’t connect through Zapier. I’m trying to connect Facebook lead generation ads to InfusionSoft by Keap. It gives this message: ERROR: (#100) Page Public Metadata Access requires either app secret proof or an app token. Is there any solution yet?

Userlevel 7
Badge +12

Hi @GWF We know that this issue has been resolved for most actions but occasionally some people are still seeing errors when they Create a Page post.


When someone runs into this issue, we spend some time with them checking their Facebook permissions. Sometimes, the issue is related to some of the permissions in their account. Could you please get in touch with the Zapier Support Team using the Get Help form. They will be able to look through your Facebook permissions with you to understand the root of the problem.

Userlevel 7
Badge +12

@Daniel Contreras It sounds like you’ve had a lot of trouble with your Facebook Zaps, I’m sorry about that!

There are so many different permissions needed when using Facebook that setting up and maintaining Zaps can be difficult. If you are still having an issue with your Zaps, the best thing to do is to get in touch with the Support team using the Get Help form, as they will be able to take a closer look with you. Thank you!

Hi, I am unable to turn my zap on because there’s an error with the  Page Public Content Access. Can you help me resolve?

Userlevel 7
Badge +8

Hi, I am unable to turn my zap on because there’s an error with the  Page Public Content Access. Can you help me resolve?


Hi @Paulina - We’ve compiled a few common issue that arise from using this integration here:

If you find yourself still needing help after giving the above help page a read, we highly suggest contacting the Support team: