Question

How do I create a Request in Jobber from a Jotform submission?

  • 2 November 2023
  • 15 replies
  • 110 views

I’ve easily create a Zap that takes a JOTFORM submission and creates a client in JOBBER. I then added on the SubZap to then create a Request in Jobber from the same Jotform submission. I believe you have to make the client first. Whether alone or as a subzap, I get the same error when I test the Request zap: “The client ID must be a number”. But I have and or see no field in Jobber for ID number. Any ideas? 


This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

15 replies

Userlevel 7
Badge +14

Hi @dkrinetz 

Good question.

To give us enough context, please post screenshots with how your Zap steps are configured.

Below are the 3 steps I. tried. I also tried others but no go.

  • In #1, the app/event connects to Jotform for the latest submission. 
  • In #2, it creates a CLIENT in Jobber from the Jotform Storage… ( I assume that since Jobber requires the Client be established first, before a Request, I reasoned this Zap first.)
  • In #3, I then attempt to create a Request in Jobber. it asks for the Client, So I applied the Answers Student Full Name from the Jotform. I assume it checks the submission against the Client established in step 2.
  • In #4, you can see the error I get for the Client ID, of which I have no idea what it’s referring to as there are no IDs in Jobber, that I can see or know of. 

 

 

Userlevel 7
Badge +14

@dkrinetz 

In Step 3, the Client field expects the internal Client ID from Step 2.

 

What is the internal Client ID? Where would that come from? The Jotform or Jobber? Attached in #1 I click on Custom. If I select New Submission in Jotform, and then select the jotform SUBMISSION ID, I get an Internal Server Error. If I select Client, as in #2, not sure where to go from there. 

 

 

 

Userlevel 7
Badge +14

@dkrinetz 

In Step 2, you are creating a Client and that will return an ID for the Jobber Client.

Map that ID from Step 2 to Step 3.

You state “and that will return an ID for the Jobber Client.” I am not sure if I am supposed to see that ID number in Step 2, but I do not. Supposing I am not gonna see it, I move on to Step 3. Again a little lost. I can click on Client or Custom. I selected Custom, and then client in Jobber, and the only field that seems right is ID as in the attached image. But get another error. And I just want to thank you for your help thus far. 

 

 

 

Userlevel 7
Badge +14

@dkrinetz 

This is the Client ID to map from Step 2.

 

We would need to see screenshots with how your Zap Step action section is configured now along with the full error message since it’s cutoff on the right.

 

Rather than more screenshots and explanations, below is a link to a video screen capture that shows it all.

https://www.veed.io/view/43c80c2c-188f-4274-b459-24a34908132d?panel=share

Userlevel 7
Badge +14

@dkrinetz 

Try clicking the [Refresh fields] button to see if that exposes more fields to fill in related to creating the request.

 

It doesn’t. 

Userlevel 7
Badge +14

@dkrinetz 

You can try reaching out to Jobber Support for guidance about their Zap app behavior.

thanks

Userlevel 7
Badge +6

Hi there @dkrinetz,

I’m jumping in to see if I can help!

Kindly try the following and let me know if the fields show up:

  • Remove what has been mapped to the “Client” field and instead manually type the client ID 75165690 in that field as a custom value
  • After doing that, still in that step, click on Refresh fields
  • If the fields show up, map the values that you want to map to the fields, then go back to the “Client” field, delete what you manually typed there, and map the ID from step 2 (just like how it was initially).

Could you please give that a try, and let me know how it goes?

Same issue exists as you can see from the video link below.

https://www.veed.io/view/7dbfc327-64c4-40a3-906f-5601e46260e7?panel=share

 

Userlevel 7
Badge +6

Thanks for the video here @dkrinetz!

It looks like you are already in contact with our Support Team regarding this issue. To ensure you get the most thorough assistance, I'd suggest keeping the conversation going through email. Our Support Team has the perfect set of tools to examine your Zap in detail and delve into the logs to pinpoint exactly what's going on.

If you can’t locate their reply I’d recommend searching your spam/junk folder or searching your inbox for any emails from zapier.com in case. Sometimes their emails can end up in the spam/junk folder by accident.

Thank you for your understanding.