Question

How do I create a habit tracking button that resets daily without creating new rows using Zapier?

  • 29 January 2024
  • 7 replies
  • 51 views

Hi,

I am trying to add a simple habit tracking button on Interfaces.

 

I used this template (https://zapier.com/templates/daily-habit-tracker) and its table to recreate the concept. 

The problem I was facing, when the new day starts a new row appears.
The check button should simply reset and the number of days should be increasing. 

 

Now everyday a new row will be created, which is not useful at all.

 

Is there a way I can reset the first row from YES to NO after midnight, and keep counting the writing days without creating new rows?

 


Thanks.
Mohammed


This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

7 replies

Userlevel 7
Badge +11

Hey there @Mohammed Abdullah! 👋

It appears that the template is currently designed to list the records for each day separately in the tracking log, so it’s expected that it would output each day as a new row like so:
115070129da27868452d60e6904ee155.png

The number total “writing” days would be updated by the connected Habit marked complete/incomplete Zap which would run when the toggle is either selected or deselected (updating the record) then check for the corresponding record in the table and then update the corresponding Completed Days value. 

To alter the functionality here you’d need to edit the connected Zaps to change what happens when the habit is marked as complete for the day:
55ae97ff7af13ac2cfd30be243312004.png

It looks as though the Every Day, Create Habit Checklist Zap is the one that creates a new row each day. If you turn off that Zap it will stop adding a new row, allowing just one record for the writing habit to be present in the table. But, I’ve not been able to test this over several days so I can’t confirm whether that would break the rest of the habit tracking functionality that’s in place.

If it’s just a case that you don’t want the tracking log to be displayed perhaps it might be better to just delete that component from the page:
f9ec908622f2efe304e4a5e03dc1d38a.png
That should remove it from the page so it’s not visible and keep the existing habit tracking functionality in tact.

Hope that helps to get you pointed in the right direction. Please do let us know how you get on with this! 🙂

Hi Sam,

 

Thanks for your answer, I tried this solution but for some reason I kept facing an error, and the switch button did not go back the next day.. 
Is there a way I can book a session with a Zap expert who can help me do it on a Zoom call or something?

 

Thanks a lot.
Mohammed

Userlevel 7
Badge +11

Thanks for giving that a try @Mohammed Abdullah. I’m sorry it didn’t work as hoped.

Yes, there are a number of certified Zapier experts you can get in touch with for more 1:1 help. You can see all the available experts and get in touch with them here: https://zapier.com/experts

That said, I’m happy to help troubleshoot this further here. Just share a screenshot of the error you’re getting as well as the current set up of any Zap actions you may have edited and we’ll go from there! 

Hi @SamB ,

 

Thanks for offering to support with this. I really appreciate it.

 

The difference in my use case, is that I have specific users (20 of them) each one of them should see their own (check mark and number of days they did the habit). 

 

So I wasnt sure how can I manage to show each user only their progress. 

Here are a few screenshots of the issues I am facing.

 

There is the error message here:

 

Then there is the issue that (Today field) is marked for all users, I dont know how to structure this in one table:

 

Thanks a lot again.

 

Best regards,

Mohammed

Userlevel 7
Badge +11

Hi @Mohammed Abdullah! 👋

Hmm, that error seems to suggest that the Zap is attempting to reference a table that doesn’t exist. Can you confirm whether the table that’s been selected in the Zap is correct? 

If so, can you share a screenshot showing what fields and settings have been selected in the Action section of that Zapier Tables action that errored? Please remove/hide any private information (like names, emails, addresses etc.) from any screenshots before sharing.

If the Zap doesn’t have the correct table selected can you select the correct table and then re-test it again to see if it works correctly?

With those 20 users are you using the managed user’s feature in Interfaces? If so, you’d need to set up a dynamic filter on the table to only show the record that’s relevant to them. See our Use dynamic filters to show personalized information guide for more details on how to set that up.

Looking forward to hearing from you on this!

Hi Sam, @SamB 

 

Thanks for your input, I tried to implement these steps and I noticed that ‘Paths’ is now on the premium plan of Zaps so I would have to subscribe to that first before being able to implement this workflow.

 

Is there another way I can do it without using ‘Paths’? If there is a template out there that I can replicate that would be very helpful.

 

I appreciate your support!

Mohammed 

Userlevel 7
Badge +11

I’m so sorry for the delay in my reply here, @Mohammed Abdullah

You could replicate the same kind of branching logic that Paths provides by using a Filter across multiple Zaps instead. There isn’t an existing template that I can share for this but we have a help guide that explains how to set up branching logic using filters instead of paths here: Add branching logic to Zaps with filters
 

If you run into any issues on that or have further questions do let me know. 😁