Skip to main content

Hey guys, 

so i created a zap that send automatic email to my customers based on when a new google sheet row has been created, in each row i have a colon called “status” that is set to either TURE, or FLASE which helps me track if the contact had been informed that we got his email or not.

i want my zap to also update that colon to TRUE after the email was sent successfully.
i have locked the cells that should not be edited to prevent zappier from editing them and ive created an “update row” step but for some reason its not working even know that specific colon does not have protection on it(and yes the account does have edit permissions) 

please help me understand how to do this correctly 

Hi @chroma 

Provide more context by posting screenshots with how your Zap steps are outlined and configured in EDIT mode.


i just want it to go in this order. 

new google sheet row(trigger) > send an email to ”email” > look at “status colon” on the new row > if =FALSE change to TRUE

 

 


@chroma 

The Row field expects a numerical value of the Row that was found in Step 3, so map one of these variables:

  • Row
  • ID

 


@troy

i tried that before but because i have protection on certain cells it wont edit the status colon which is stupid, i specificly did that so the zap wont mess with any of my data and only be able to edit the colon of status

This is the error:

Failed to create a spreadsheet row in Google Sheets

There was an error writing to your Google sheet. You are trying to edit a protected cell or object. Please contact the spreadsheet owner to remove protection if you need to edit.

show more

Click on the Troubleshoot tab below or learn more in our help center.”


@chroma 

Help article to reference: https://help.zapier.com/hc/en-us/articles/25804519400461-Google-Sheets-error-There-was-an-error-writing-to-your-Google-Sheets-unable-to-parse-range

 

Google Sheets error: There was an error writing to your Google Sheets, unable to parse range

 

Symptoms

When you use a create or update action in a Google Sheets step, you see an error message of "There was an error writing to your Google Sheets, unable to parse range". This happens when testing the Zap or if the Zap is live.

Causes

This can happen for a few reasons:

  • A column in the sheet has been removed.
  • The sheet has been renamed.
  • Insufficient permissions.
  • Some of the rows or columns are frozen, hidden, or protected.

How to fix it

To fix this:

  1. Check the sheet name and the range of columns and rows used by your Zap to ensure it matches what you see in Google Sheets.
  2. Verify that the Google account connected to the Zap has editor permissions for that sheet.
  3. Check if any rows or columns being used by the Zap are frozen, hidden, or protected in Google Sheets. Adjust them, if necessary, as Zaps cannot work with frozen, hidden, or protected columns and rows.

Hi @chroma,

 

We just wanted to see how everything is going with your Zap. Did Troy's recommendation get the job done? Feel free to reach out if you need further assistance with your Zap. We're glad to address any concerns and assist you.

 

We're looking forward to your response.


Thank you @troy for the help, i really appreciate it 


hey @JammerS 
so i actually gave up on using this specific zap and ive moved to a solution that worked better for me which is custom code using google script for my zap, i couldent get the zap to work and the code does exactly what i need making it the better choice.

Thank you