Best answer

How do I associate Quickbooks invoices to Salesforce based on account ID?

  • 8 June 2022
  • 7 replies
  • 259 views

Userlevel 1

Hi,

I am a newbie to this so I hope I am not asking something that makes no sense. We are a small companies with many disconnected systems and to try and tie many of them together, we decided to push or pull most data together in SF (best for reporting for us, etc). And we use the SF AccountID field as the common field to tie them. So all Zendesk accounts have an AccountID (the SF one), and all Quickbooks customers and invoices have this Account ID as well. Here is what I would like to do but so I could not figure out if this is doable. 

If an invoice is created and it has an account id, i want to push the info that an invoice was sent and the invoice number to that account in salesforce that matched the account id of the invoice. The same when the invoice is paid. 

I can easily do the first part, if invoice is created and has an account it field that is not empty

but I have no idea if it is even possible and how to out the info into the SF account that matches this ID. I assume i am dreaming if i think this can be done with zapier but i wanted to check anyways.  

icon

Best answer by christina.d 15 June 2022, 00:23

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

7 replies

Userlevel 7
Badge +14

Hi @hoodoo 

Good question.

By SF, do you mean Salesforce?

Have you tried using one of these Zap actions:

 

Then create or update a record and link it to the previously found record using the Salesforce Record ID.

OR

 

Userlevel 1

Ok sorry but I try to wrap by head around it. So say the account ID is 1234 and invoice number is 9999

So I start my zap by adding QB’s so when a new invoice is crated and I then add a ZAPIER Filter to make sure AccountID field is not empty. I get back the results that there is one, AccountID is: 1234 and Invoice number is 9999. so now what? 

I am not clear how I can now search that the QB’s Account ID has a match in SalesForce (in the account id field) and only then, I would enter details about the QB’s invoice (invoice number) to the Salesforce Opportunity field (Invoice sent)

 

 

Userlevel 7
Badge +14

@hoodoo 

Have you tried adding a Salesforce Find Record step to your Zap and testing that?

 

Userlevel 1

I will do some tests today. maybe doing it will make this more logical. when I looked at it first it was easy how to search for a specific record in a new invoice and also how to find the SF field i am looking for but i could not figure out how to enter something into a specific field if this SF AccountID (in accounts) matches the value on the invoice. i will try it out maybe it comes to me then :)

thanks

 

Userlevel 1

Ok, so I played around with it but I can’t make the connection just as I expected. I can find if an invoice is created that has a specific field that is filled with something starting with 00 (QB’s+if starts with 00). I then added SalesForce to find the customer in SF that matches the number from the QB’s invoice field and that worked as well. But I have no idea how to then proceed, to now enter info from the invoice into other SF fields (or one field). 

 

Userlevel 7
Badge +9

​Hey there, @hoodoo! I can see you were able to open a ticket with our friends in support - which is perfect. They confirmed it looks like we’re working with a known bug with the SalesForce app where only the first 3 custom fields are pulling through.

https://help.developer.intuit.com/s/article/API-response-not-showing-existing-custom-field

That said it looks like you were able to have some success with these recommended steps: 

  • Login to the QBO Advanced account.
  • Go to Settings (Gear Icon) > LISTS > Custom fields
  • Toggle the button to 'Include inactive'.
  • Now, verify which custom fields should be visible in the API response.

Doing some searching for this issue online, some users found success with removing extra custom fields they don't use so that the one they want to use is shown in the top 3 that get sent over the API  

 

You were added as an impacted user on this bug report so while we don’t have an ETA to share at the moment, we’ll notify you via email once a fix is in place. We’ll also be sure to update the thread!

Thanks again for reaching out! 🙂

Userlevel 1

actually it is all fixed and working mainly due to some help from the @getuwired.com team. They put me on the right path. the custom fields were not the issue (even they are an issue). I realized that between quickbooks and zapier it is not just limited to 3 custom fields but if you make an existing one inactive and add new ones, none of them will ever show up even if you have less than 3. I was able to just make an old one active again and rename it and voila, it worked.