Best answer

Google Tasks error connecting to Zapier

  • 25 February 2021
  • 34 replies

Userlevel 1

Hi all,


I’ve been unsuccessfully trying to connect Zapier to Google Tasks (to send tasks to Todoist).

I choose the proper Google account which I use for tasks and get the following message:


Zapier could not connect to your account.

The app returned "Invalid grant_type:".


No connection to the app is formed.

Has anyone had this issue and successfully solved it?

Note: I use the same google account to connect to Zapier. Not sure if that may be causing issues.

Thank you!


Best answer by Danvers 8 March 2021, 14:46

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

34 replies

Userlevel 7
Badge +12

@djacob, @Dave Ferrick and @aviranos, I’ve added you as affected users on the issue. Thanks!

@Danvers  Please add me to list of people unable to connect

Same issue, may I please be added to the notification list?

me too

@Danvers Please add me to the email list too. Thanks!

Userlevel 7
Badge +8

@mikeoliveraz @HC101 @shelshok you all have been added!

Hi there, 

there’s same for me, 

and I tried to connect Zapier to Google Tasks on my phone and PC,

it’s same error, 


Userlevel 1

Hey all, just got news about a deployed fix for this.

Just tried it and managed to connect Google Tasks to Zapier. Try it out and see if it solves for you guys.

Thanks to the Zapier team for the swift fix on this!


Userlevel 7
Badge +8

Thanks for sharing so quickly @kurashu ! Confirming that the fix has been deployed- if anyone is encountering any additional issues, please reach out to our Support Team here.

Userlevel 7
Badge +12

Hi everyone!

I’m very happy to report that this bug has now been fixed!

If you’re having any other trouble connecting your Google Tasks account to Zapier the Support Team will be able to take a look at this with you. You can contact them using the Get Help form