Best answer

Google sheets to Podio

  • 19 March 2020
  • 5 replies

I have a zap where each time a row is entered or edited in Google sheets, it creates an item in podio.  This zap was working fine for weeks and now all of a sudden it has stopped.  The error code in zapier says “the app returned invalid value”.  I understand this means that a field came back empty or not formatted correctly.  I turned the zap off, went into google sheets, fixed the fields that zapier said were empty or not formatted correctly, and then turned the zap back on.  It is still not working.  The weird thing is that for weeks prior to now, zapier was pulling the info from google sheets into podio even if there were empty fields.  Now all of a sudden, those empty fields are causing a problem.  Even if I fill the field and retry the zap it still is not working.  What can I do to fix this?  The zap worked 70+ times last month without a problem and now it’s not even though nothing has changed.  Please help! TIA!


Best answer by Liz_Roberts 6 April 2020, 21:00

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

5 replies

Userlevel 7
Badge +12

Hi @jtrinh Thanks for your question and I’m sorry for the delay in getting a response!

When you look at the task history for the Zap, is it hitting an error every time, or only on some occasions? And if it’s not every time, is there anything that links those times when it does error? eg is there a specific field missing? 


Hi @Danvers ,


This has only happened since 3/16 and does not happen every time.  Each time that it does occur the error comes back the same (as “invalid value”) but it does that only on some zaps and not others.  So the zap works on some of the google rows and not others even if both rows have missing fields.  Even if I go back into the sheet, fill in the field, and then turn the zap back on, it is still coming up as an error.  I am not sure why some rows can have empty fields and the zap goes through fine, but then other rows have empty rows and error.  Any suggestions?



Userlevel 7
Badge +12

I think that we need have someone from the Support team take a closer look at those tasks where the Zap hits and error. I've escalated this to the Support team and someone will be touch via email to help you with it as soon as possible. 

Ok, thank you, i will wait to hear from someone on the support team…...

Userlevel 7
Badge +8

Hi @jtrinh ,

Circling back on this as I see you have been working with Support! It looks like the character limit in the phone number field was causing the error. Once the Google sheet cell that mapped the phone numbers is less than 50 characters, this error should be resolved! 

Please let us know if you are still encountering any issues and we’ll be happy to help!