Google Sheets add update record to SQL server

  • 2 June 2023
  • 4 replies

Userlevel 1

hallo, i have tried using template google sheet to sql, how to add update record in google sheets to sql? please help

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

4 replies

Userlevel 7
Badge +12

Hi @aruza88, welcome to the community!

So we can best help you, could you please describe what you’re trying to do in more detail? Could you share a link to the Zap template you’re using? And could you explain what you would like to happen eg when a new row is added to Google Sheets, add the information in the row to SQL.  If you’re stuck on a specific part of the Zap, or are seeing an error message, could you share a screenshot of that step in the Zap editor? Don’t forget to remove or obscure any personal or private information in any screenshot you share in the community (eg full name, email address, etc).


It sounds like you’re pretty new to Zapier, so I recommend looking at some of these resources, which are helpful for Zapier beginners:

Zapier Learn customer onboarding course - some lessons that walk you through the fundamentals of Zapier

Send data between steps by mapping fields - a help guide on how to setup Zap steps to send information between apps. 


​I hope that helps, please let us know if you have any questions!

Userlevel 1

Sorry, i mean, integrate google sheet update record to sql server,in zapier  first step i hv tried create google sheet trigger event add and update record,step two second i create sql server find record and step 3 i create update record to sql. I think i hv mistake action in step 2 or 3. I little confuse. How step by step create action update to sql

Userlevel 1

Please help flow integrate update record google sheet to sql server

Userlevel 7
Badge +11

Thanks for sharing those screenshots and additional details here, @aruza88

It seems like you’re wanting to replicate updates that happen in Google Sheets in your SQL Server but it’s not it’s not updating the the row in SQL Server as expected. Am I understanding that correctly? 

If so, it looks like most of the select fields from the Google Sheets trigger don’t have any values present so nothing will be updated in the row on SQL Server when testing:

It also seems that the TradeID is being selected from the Google Sheets trigger, rather than taking the value from the Find Row action, so it might not be updating the same row that is found by the Find Row action. In which case you may want to tweak the Row field on that Update Row action slightly so that it’s referencing the tradeID for row that was found by the previous Find Row (SQL Server) action:
That should ensure that the Zap will update the same row that is found by the Find Row action. That is assuming the tradeID is unique to that specific row. If it’s not then you’d need to change the Row and ID Column fields to reference a more unique value for the row.

Can you give that a try and confirm whether that fixes things here? 

And if I’ve misunderstood the issue here, just let me know and we’ll go from there! 🙂