Best answer

Google Sheet Lookup Step success/fail result not showing up in subsequent filter options unless "Create Row if nothing exists" is selected

  • 27 April 2021
  • 8 replies
  • 156 views

Userlevel 1

I have multiple zaps that use the Google Sheets look up row action and previously, I could use whether the look up was successful or not in a later filter or path, but now it is only giving me that option if I also choose the “Create row if nothing exists” option, which I don’t always want. Otherwise the “Zap Data Was Found” filter for that look up action doesn’t exist.

I have the “Should This Step Be Considered A "success" When Nothing Is Found?” setting set to True. Has something changed in how the look up action results are able to be used in filters or has something gone wrong?

icon

Best answer by nicksimard 23 July 2021, 01:15

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

8 replies

Userlevel 7
Badge +14

Hi @AshleighDLC 

The Zap will now return this data point that can be used in Filters

 

Userlevel 1

Hi @Troy Tessalone 

I just checked one of my zaps again and it is still doing the same thing. Unless I check “Create row if none exists”, it does not return a search result status to use in a filter. 

I have attached some screen shots. I left Action 3 as is, without the create row box checked, and in the filter did several field searches that should have brought up the look up result and you can see nothing comes up. 

Then I changed Action 4 (which is normally set up the same way as 3) by checking the create row box, and you can see in the filter search that the look up result comes up immediately. 

When I first opened this zap to make an adjustment, the filter dropdown where I had previously entered the zap look up result in was empty. I have multiple zaps that use a filter like this and I’m concerned that they may be filtering incorrectly if this isn’t working.

Userlevel 7
Badge +14

@AshleighDLC 

I was able to replicate the use case.

I’ve gone ahead and flagged this post for the Zapier Team to review.

I’ve also submitted a ticket to Zapier Support on your behalf here: https://zapier.com/app/get-help

Userlevel 7
Badge +14

@AshleighDLC

Here’s the response I got from Zapier Support:

I took a look a the article and I was able to reproduce it as well.

It looks like it's a platform level issue as I could reproduce with Airtable and Google Sheets searches.

I don't think it was intentional.

I've gone ahead and created a bug report so that we can look into this and we'll notify you automatically when it's resolved.

Userlevel 1

Hi @Troy Tessalone  Thanks for that. When they say that they will update automatically, will that update also go to me?

Userlevel 7
Badge +14

@AshleighDLC 

Not sure since I opened the ticket, but mentioned this Zapier Community article indicating you were the original reporter.

You can always reach out to Zapier Support to have them make sure you are included on the update statuses.

Userlevel 7
Badge +11

Hi @AshleighDLC!

I’ve added a link to this thread in that bug report, so an update should be posted here when that’s been resolved :)

Userlevel 7
Badge +11

Just wanted to let everyone on this thread know that this issue has been resolved! You should no longer be running into this problem :) If for some reason you continue to experience this bug, please contact our Support team to let them know.