Question

Google Doc PDF not consistently being added to email as attachment

  • 19 March 2022
  • 1 reply
  • 22 views

See previous post for background info: 

I have a Zap set up that does the following steps

  1. Checks for New/Updated records in an Airtable view
  2. Creates a Google Doc from a template based on the info in the record
  3. Emails that Google Doc out as a PDF attachment to the email address in the Airtable record (By attaching the Export Links Application/pdf link from the previous step)

Upon trying this again with a “Delay After Queue” step implemented, most of the emails sent were completely fine and attached the PDF as intended. But a random selection of records, the attachment to the email was ServiceLogin.htm, and my clients weren’t able to access the PDF.

Anyone have this happen or have a workaround for how to prevent it from happening in the future? 

I received advice to try adding in the delay step - which didn’t work. I also tried doing smaller batches (I was initially doing 200 - I’m now only doing 40 - edit: tried it with 5 and it still happened) - and the issue still happened. I saw some posts indicating that it was something timing out - is there a way to fix it? Seems like Zapier may not be the solution for me if this keeps happening.

Thanks for any advice!

 
 

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

1 reply

Userlevel 7
Badge +14

Hi @user138 

Good question.

You may need a longer Delay After Queue buffer.

What is your Delay After Queue currently set to?