Best answer

Getting “incorrect username and/or password” error when connecting to WooCommerce

  • 5 February 2021
  • 3 replies
  • 518 views

I am trying to setup a zap with woocommerce, it just can’t authenticate, kept saying my username and pwd are incorrect although they are correct. (One thing zapier can do is to reveal the pwd that I typed btw).

I read the documentation many times, disabled jetpack single sign-on module and some other mentioned plugins, to no avail. What to do? Do I really have to disable all my other plug-ins one-by-one? This process is very frustrating and I have spent hours on this.

And ***if*** there is indeed a plug-in that is conflicting, does it mean it has to stay deactivated if I want the zap to run, or, it only impacts this one-time zap-setup phase and I can turn it back on after setting up the zap, and they can co-exist?  (even though I can’t see any suspicious plug-in though, and I would really hate to disable one by one to try this out!)

Help!

-leana

icon

Best answer by SamB 14 July 2021, 13:10

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

3 replies

Userlevel 7
Badge +10

Hi @wleana 

Sadly, Wordpress can be so temperamental when external apps connect to it (like Zapier), so many things - from your hosts various security settings, to plugin conflicts can be a cause - it’s hard to narrow things down.

As suggested whenever there are plugin conflicts in WP, the best thing to do is turn them all off and back on one-by-one. Once you’ve found the offending plugin you can look at workarounds.

Need to install any plugin for that?

 

Userlevel 7
Badge +11

Just wanted to follow up here as it looks like @hemlata reached out to our Support team who shared WooCommerce’s help guide that covers ways to solve different types of authentication issues here: Authentication Errors In Zapier.com

 

The very first option in the list relates to the error "The username and/or password you supplied is incorrect":

ef8c04d8ba3bf325e31c0c849893d0ce.png

For anyone running into similar authentication issues with WooCommerce, if the steps on that help guide don’t help to resolve things, please reach out to our Support team here who will be happy to assist further! :)