Best answer

Getting data from Google Form to Google Sheet for sending Gmail thank you

  • 15 March 2020
  • 2 replies

I’m using Google Forms to populate a Google Sheet then grabbing new information using Zapier to send a personalized thank you email using Business Gmail. A few weeks ago everything worked, now none of the data is being used by gmail and the send using gmail will not work. I’ve tried every fix I can find (and understand) but cannot get it working. Any clues or help please. Thank you.


Best answer by steph.n 29 April 2020, 17:45

View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

2 replies

Userlevel 7
Badge +12

Hi @Bill Vick

So, the Zap is being triggered but the information isn’t correctly being used in the Gmail and so the Gmail wont send, is that right?

The first thing to check is if there are any blank rows in the Google Sheet as this can mess with Google Sheets Zaps. If there are, turn off the Zap, delete the blank row and turn the Zap back on again. 

If there aren’t any any empty rows, could you give us a bit more information about the error that you’re seeing? Is the Zap not finding any information in the Google Sheet or is it trying to use the wrong information? And is does it fail every time, or only sometimes?

Userlevel 7
Badge +8

Hi @Bill Vick - We noticed that you received an answer from Support so I’m going to share it here:

If we look at the last task that ran on July 30 - we can see that it was in Row 1377 of the Sheet.


But if we look at the Sheet today - we are only at Row 1301.

This tells me some rows were deleted from the Sheet at some point after that last run on July 30th..

Due to the way we look for New Rows - deleting rows while the Zap is ON can cause issues just like this where the Zap doesn't trigger.

If you do need to delete rows form the Sheet - it is always best to Turn the Zap OFF, delete the rows, and then Turn the Zap ON again.

Turning the Zap OFF/ON will reset the tables we use to check for New Rows.

So when you did that today - the Zap started working again.