Getting 403 error while connecting azure web app account using Deployment Trigger URL.

  • 25 April 2020
  • 6 replies

Userlevel 1

I have an issue with 'Azure Web App' application used for PostDeployment email notifications. I'm getting 403 error ("authentication failed: Unexpected token < in JSON at position 0") while trying to add new account. Please note that I have about 30 zaps that were setup in the same way and they are working as expected. But while hitting "Test" button for each saved Azure Web App account I'm getting the same 403 error.
I did not find a way to refresh azure authentication on zapier side. Tried to logout from azure portal, tried different browsers but nothing helped.
Please see attached sreenshots for more information.

Thanks a lot for your attention.

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

6 replies

Userlevel 7
Badge +8

Hi @Upeo Dev ,

Thanks for reaching out and sorry you are encountering this 403 error!

I see you are working with Support on this issue- they’re the right folks to tackle this as they will be able to hop into your Zap and troubleshoot from there. 

In the meantime, please let us know if we can be of any further help or answer any additional questions!


I have the exact same problem. Could you share the solution?



Userlevel 7
Badge +10

@Kulcsár Gábor 

I'm going to flag this post for the Zapier Community Team. They should have more insight on this and can escalate to the support team if needed.

Sit tight, and someone will contact you soon.

Userlevel 7
Badge +12

Hi @Kulcsár Gábor I’m sorry that you’re having trouble with your Zaps. It sounds like this might be related to an issue that we’re currently seeing with the Azure Web Apps integration. So that we can double check this, I’m going to escalate it to the Support Team so that they can take a closer look. Someone will be in touch via email as soon as possible. 

Userlevel 1

Hello there!

I found that my existing zaps are referring to Azure Web Apps (1.7.0) now an they have authorization problems. Seems now I need to change Azure Web Apps to the latest version and reassigne azure deployment trigger URL accounts.

My first feedback about this problem was posted directly to support few months ago (I suppose in the beginning of the year), then I’ve duplicated my feedback to support directly and posted it here. Guys, I know that it is impossible to fix bugs immediately, but during about a half a year I had not working functionality.

Anyway thank you for fixing this issue and have a good day there!

Userlevel 7
Badge +12

Hi there @Upeo Dev! I’m sorry that this is an ongoing issue for you, it sounds really frustrating. 


The Azure Web Apps Zapier integration is owned and maintained by the Azure Web Apps team; we’ve let them know about the issue and are working with them to help them to resolve it but we can’t fix it on their behalf. You can, of course, get in touch with their team if you’d like to ask them to take a look at this issue.